summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2011-08-26 21:22:00 (UTC)
committer Michael Krelin <hacker@klever.net>2011-08-26 21:22:00 (UTC)
commit1d00b262ddf0d6c3207a4b796d48899ed79bffcd (patch) (unidiff)
tree03d745873ba13ffb0e2fe1831ecb41f7c0b05758 /configure.ac
downloadcliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.zip
cliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.tar.gz
cliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.tar.bz2
initial commit into the public repository0.0
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..4ecdb31
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,23 @@
1AC_INIT([cliche],[0.0],[cliche-bugs@klever.net])
2AC_CONFIG_SRCDIR([src/cliche.rl])
3AC_CONFIG_HEADERS([config.h])
4AM_INIT_AUTOMAKE([check-news dist-bzip2 parallel-tests color-tests])
5
6AC_PROG_INSTALL
7AC_PROG_CXX
8AC_PATH_PROG([RAGEL],[ragel],[false])
9test "$RAGEL" = "false" && AC_MSG_ERROR([No ragel FSM compiler found])
10AC_PROG_SED
11
12AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
13
14AC_CHECK_FUNC([getopt_long],[
15 AC_DEFINE([HAVE_GETOPT_LONG],[1],[define to make use of getopt_long])
16])
17
18AC_CONFIG_FILES([
19 Makefile
20 src/Makefile
21 test/Makefile
22])
23AC_OUTPUT