summaryrefslogtreecommitdiffabout
path: root/src/Makefile.am
authorMichael Krelin <hacker@klever.net>2011-08-26 21:22:00 (UTC)
committer Michael Krelin <hacker@klever.net>2011-08-26 21:22:00 (UTC)
commit1d00b262ddf0d6c3207a4b796d48899ed79bffcd (patch) (unidiff)
tree03d745873ba13ffb0e2fe1831ecb41f7c0b05758 /src/Makefile.am
downloadcliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.zip
cliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.tar.gz
cliche-1d00b262ddf0d6c3207a4b796d48899ed79bffcd.tar.bz2
initial commit into the public repository0.0
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'src/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d5102a7
--- a/dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,15 @@
1bin_PROGRAMS = cliche
2man_MANS = cliche.1
3
4EXTRA_DIST=$(man_MANS)
5
6cliche_SOURCES = cliche.rl COPYING.cc
7CLEANFILES=cliche.cc
8
9COPYING.cc: ${top_srcdir}/COPYING
10 (echo 'const char *COPYING=' \
11 && $(SED) -e 's/"/\\"/g' -e 's/^/\"/' -e 's/$$/\\n\"/' \
12 && echo ';') <$< >$@ || (rm $@;exit 1)
13
14.rl.cc:
15 $(RAGEL) -C -o $@ $<