summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Side-by-side diff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 06aeaae..a3236ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,12 +11,15 @@ XPI=${PACKAGE}-${VERSION}.xpi
xpi: ${XPI}
${XPI}: install
- test -z "${NO_UPDATE}" || sed -i -e '/em:updateURL/d' ${xpidir}/install.rdf
+ test -z "${NO_UPDATE}" || sed -i -e '/em:update\(URL\|Key\)/d' ${xpidir}/install.rdf
cd ${xpichromedir} \
&& ${ZIP} -r -m ${PACKAGE}.jar */
cd ${xpidir} \
&& ${ZIP} -r @abs_builddir@/$@ .
+update.rdf: update-template.rdf ${XPI}
+ sed -e "s/<!--SHA1-->/$$(sha1sum ${XPI}|cut -d\ -f1)/" <$< >$@
+
install-data-local: ${xpidir}/chrome.manifest
${xpidir}/chrome.manifest: chrome.manifest Makefile