summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Unidiff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 06aeaae..a3236ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,18 +8,21 @@ EXTRA_DIST = NEWS NEWS.xml NEWS.xsl chrome.manifest
8 8
9XPI=${PACKAGE}-${VERSION}.xpi 9XPI=${PACKAGE}-${VERSION}.xpi
10 10
11xpi: ${XPI} 11xpi: ${XPI}
12 12
13${XPI}: install 13${XPI}: install
14 test -z "${NO_UPDATE}" || sed -i -e '/em:updateURL/d' ${xpidir}/install.rdf 14 test -z "${NO_UPDATE}" || sed -i -e '/em:update\(URL\|Key\)/d' ${xpidir}/install.rdf
15 cd ${xpichromedir} \ 15 cd ${xpichromedir} \
16 && ${ZIP} -r -m ${PACKAGE}.jar */ 16 && ${ZIP} -r -m ${PACKAGE}.jar */
17 cd ${xpidir} \ 17 cd ${xpidir} \
18 && ${ZIP} -r @abs_builddir@/$@ . 18 && ${ZIP} -r @abs_builddir@/$@ .
19 19
20update.rdf: update-template.rdf ${XPI}
21 sed -e "s/<!--SHA1-->/$$(sha1sum ${XPI}|cut -d\ -f1)/" <$< >$@
22
20install-data-local: ${xpidir}/chrome.manifest 23install-data-local: ${xpidir}/chrome.manifest
21 24
22${xpidir}/chrome.manifest: chrome.manifest Makefile 25${xpidir}/chrome.manifest: chrome.manifest Makefile
23 sed \ 26 sed \
24 -e 's,^content[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,content \1 jar:chrome/${PACKAGE}.jar!/\2,' \ 27 -e 's,^content[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,content \1 jar:chrome/${PACKAGE}.jar!/\2,' \
25 -e 's,^locale[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,locale \1 \2 jar:chrome/${PACKAGE}.jar!/\3,' \ 28 -e 's,^locale[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,locale \1 \2 jar:chrome/${PACKAGE}.jar!/\3,' \