author | Michael Krelin <hacker@klever.net> | 2010-03-02 22:13:23 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2010-03-08 00:14:30 (UTC) |
commit | 02ba82674ce4c5983130a2501169e013b70a95fa (patch) (unidiff) | |
tree | 381eead49cedf960378a7d418fe7ac957d704afb /src/Makefile.am | |
parent | ce549cc7cc156ff1d6e15bcceb6c6178154af459 (diff) | |
download | iii-02ba82674ce4c5983130a2501169e013b70a95fa.zip iii-02ba82674ce4c5983130a2501169e013b70a95fa.tar.gz iii-02ba82674ce4c5983130a2501169e013b70a95fa.tar.bz2 |
introducing iii-extract-riff-chunk utility
for getting the timestamp out of Nikon AVIs
Signed-off-by: Michael Krelin <hacker@klever.net>
-rw-r--r-- | src/Makefile.am | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am index b5b7d5c..b31bed5 100644 --- a/src/Makefile.am +++ b/src/Makefile.am | |||
@@ -1,32 +1,36 @@ | |||
1 | bin_PROGRAMS=iii-extract-riff-chunk | ||
1 | sbin_PROGRAMS=iiid | 2 | sbin_PROGRAMS=iiid |
2 | noinst_HEADERS = \ | 3 | noinst_HEADERS = \ |
3 | eyefi.h \ | 4 | eyefi.h \ |
4 | eyekinfig.h eyetil.h \ | 5 | eyekinfig.h eyetil.h \ |
5 | eyefiworker.h | 6 | eyefiworker.h |
6 | 7 | ||
7 | AM_CPPFLAGS = ${CPPFLAGS_DEBUG} \ | 8 | AM_CPPFLAGS = ${CPPFLAGS_DEBUG} \ |
8 | -DEYEKIN_CONF_DIR=\"${sysconfdir}/${PACKAGE}\" | 9 | -DEYEKIN_CONF_DIR=\"${sysconfdir}/${PACKAGE}\" |
9 | DEFAULT_INCLUDES = -I${top_builddir} -I${builddir} -I${srcdir} | 10 | DEFAULT_INCLUDES = -I${top_builddir} -I${builddir} -I${srcdir} |
10 | INCLUDES = ${MODULES_CFLAGS} ${UUID_CFLAGS} | 11 | INCLUDES = ${MODULES_CFLAGS} ${UUID_CFLAGS} |
11 | 12 | ||
12 | iiid_SOURCES = iiid.cc \ | 13 | iiid_SOURCES = iiid.cc \ |
13 | eyekinfig.cc eyetil.cc \ | 14 | eyekinfig.cc eyetil.cc \ |
14 | eyefiservice.cc eyefiworker.cc | 15 | eyefiservice.cc eyefiworker.cc |
15 | nodist_iiid_SOURCES = \ | 16 | nodist_iiid_SOURCES = \ |
16 | ${builddir}/soapC.cpp ${builddir}/soapeyefiService.cpp \ | 17 | ${builddir}/soapC.cpp ${builddir}/soapeyefiService.cpp \ |
17 | COPYING.cc | 18 | COPYING.cc |
18 | iiid_LDADD = ${MODULES_LIBS} ${UUID_LIBS} | 19 | iiid_LDADD = ${MODULES_LIBS} ${UUID_LIBS} |
19 | 20 | ||
21 | iii_extract_riff_chunk_SOURCES = iii-extract-riff-chunk.cc | ||
22 | nodist_iii_extract_riff_chunk_SOURCES = COPYING.cc | ||
23 | |||
20 | COPYING.cc: ${top_srcdir}/COPYING | 24 | COPYING.cc: ${top_srcdir}/COPYING |
21 | echo "const char * COPYING = " >$@ || (rm $@;exit 1) | 25 | echo "const char * COPYING = " >$@ || (rm $@;exit 1) |
22 | sed -e 's/"/\\"/g' -e 's/^/\"/' -e 's/$$/\\n\"/' $< >>$@ || (rm $@;exit 1) | 26 | sed -e 's/"/\\"/g' -e 's/^/\"/' -e 's/$$/\\n\"/' $< >>$@ || (rm $@;exit 1) |
23 | echo ';' >>$@ || (rm $@;exit 1) | 27 | echo ';' >>$@ || (rm $@;exit 1) |
24 | 28 | ||
25 | ${srcdir}/eyefiservice.cc: ${builddir}/soapeyefiService.h | 29 | ${srcdir}/eyefiservice.cc: ${builddir}/soapeyefiService.h |
26 | ${srcdir}/iiid.cc: ${builddir}/eyefi.nsmap | 30 | ${srcdir}/iiid.cc: ${builddir}/eyefi.nsmap |
27 | 31 | ||
28 | ${builddir}soapC.cpp ${builddir}/soapeyefiService.cpp ${builddir}/eyefi.nsmap ${builddir}/soapeyefiService.h: ${srcdir}/eyefi.h | 32 | ${builddir}soapC.cpp ${builddir}/soapeyefiService.cpp ${builddir}/eyefi.nsmap ${builddir}/soapeyefiService.h: ${srcdir}/eyefi.h |
29 | ${SOAPCPP2} -d${builddir} -S -L -a -i -w -x $< | 33 | ${SOAPCPP2} -d${builddir} -S -L -a -i -w -x $< |
30 | 34 | ||
31 | clean-local: | 35 | clean-local: |
32 | rm -f soap{{H,Stub,eyefiService}.h,{C,eyefiService}.cpp} eyefi.nsmap COPYING.cc | 36 | rm -f soap{{H,Stub,eyefiService}.h,{C,eyefiService}.cpp} eyefi.nsmap COPYING.cc |