-rw-r--r-- | configure.ac | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index c3bb8ab..2e66fc4 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -31,41 +31,41 @@ AC_CHECK_HEADERS([autosprintf.h],[ | |||
31 | AC_CHECK_LIB([asprintf],[main],,[notfound=true]) | 31 | AC_CHECK_LIB([asprintf],[main],,[notfound=true]) |
32 | ],[notfound=true]) | 32 | ],[notfound=true]) |
33 | $notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) | 33 | $notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) |
34 | AC_LANG_POP([C++]) | 34 | AC_LANG_POP([C++]) |
35 | 35 | ||
36 | nitpick=false | 36 | nitpick=false |
37 | AC_ARG_ENABLE([nitpicking], | 37 | AC_ARG_ENABLE([nitpicking], |
38 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | 38 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), |
39 | [ test "$enableval" = "no" || nitpick=true ] | 39 | [ test "$enableval" = "no" || nitpick=true ] |
40 | ) | 40 | ) |
41 | if $nitpick ; then | 41 | if $nitpick ; then |
42 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | 42 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ |
43 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | 43 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ |
44 | -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" | 44 | -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" |
45 | C_NITPICK="$CPP_NITPICK" | 45 | C_NITPICK="$CPP_NITPICK" |
46 | CXX_NITPICK="$C_NITPICK" | 46 | CXX_NITPICK="$C_NITPICK" |
47 | 47 | ||
48 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" | 48 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" |
49 | CFLAGS="$CFLAGS $C_NITPICK" | 49 | CFLAGS="$CFLAGS $C_NITPICK" |
50 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" | 50 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" |
51 | fi | 51 | fi |
52 | 52 | ||
53 | ndebug=true | 53 | ndebug=true |
54 | AC_ARG_ENABLE([debug], | 54 | AC_ARG_ENABLE([debug], |
55 | AC_HELP_STRING([--enable-debug],[enable debugginc code]), | 55 | AC_HELP_STRING([--enable-debug],[enable debugging code]), |
56 | [ test "$enableval" = "no" || ndebug=false ] | 56 | [ test "$enableval" = "no" || ndebug=false ] |
57 | ) | 57 | ) |
58 | if $ndebug ; then | 58 | if $ndebug ; then |
59 | CPPFLAGS_DEBUG="-DNDEBUG" | 59 | CPPFLAGS_DEBUG="-DNDEBUG" |
60 | else | 60 | else |
61 | CPPFLAGS_DEBUG="-DDEBUG" | 61 | CPPFLAGS_DEBUG="-DDEBUG" |
62 | fi | 62 | fi |
63 | AC_SUBST([CPPFLAGS_DEBUG]) | 63 | AC_SUBST([CPPFLAGS_DEBUG]) |
64 | 64 | ||
65 | AC_CONFIG_FILES([ | 65 | AC_CONFIG_FILES([ |
66 | Makefile | 66 | Makefile |
67 | src/Makefile | 67 | src/Makefile |
68 | doc/Makefile | 68 | doc/Makefile |
69 | doc/iiid.8 | 69 | doc/iiid.8 |
70 | ]) | 70 | ]) |
71 | AC_OUTPUT | 71 | AC_OUTPUT |