summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e0e42c..3b409fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,47 +1,50 @@
1AC_INIT([iii], [0.3], [iii-bugs@klever.net]) 1AC_INIT([iii], [0.3], [iii-bugs@klever.net])
2AC_CONFIG_SRCDIR([src/iiid.cc]) 2AC_CONFIG_SRCDIR([src/iiid.cc])
3AC_CONFIG_AUX_DIR([aux.d]) 3AC_CONFIG_AUX_DIR([aux.d])
4AC_CONFIG_HEADERS([config.h]) 4AC_CONFIG_HEADERS([config.h])
5AM_INIT_AUTOMAKE([dist-bzip2]) 5AM_INIT_AUTOMAKE([dist-bzip2])
6 6
7AC_PROG_INSTALL 7AC_PROG_INSTALL
8AC_PROG_CXX 8AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10PKG_PROG_PKG_CONFIG 10PKG_PROG_PKG_CONFIG
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13 13
14AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 14AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
15 15
16PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse]) 16PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse])
17PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 17PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
18AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 18AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
19if $have_uuid ; then 19if $have_uuid ; then
20 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 20 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
21 AC_SUBST([UUID_UUID],[uuid]) 21 AC_SUBST([UUID_UUID],[uuid])
22fi 22fi
23 23
24PKG_CHECK_MODULES([SQLITE],[sqlite3],[have_sqlite=true],[have_sqlite=false])
25$have_sqlite && AC_DEFINE([HAVE_SQLITE],,[defined in presence of libsqlite3])
26
24AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) 27AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false])
25test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) 28test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.])
26 29
27notfound=false 30notfound=false
28AC_CHECK_HEADERS([archive.h],[ 31AC_CHECK_HEADERS([archive.h],[
29 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) 32 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true])
30],[notfound=true]) 33],[notfound=true])
31$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) 34$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/])
32 35
33notfound=false 36notfound=false
34AC_LANG_PUSH([C++]) 37AC_LANG_PUSH([C++])
35AC_CHECK_HEADERS([autosprintf.h],[ 38AC_CHECK_HEADERS([autosprintf.h],[
36 AC_CHECK_LIB([asprintf],[main],,[notfound=true]) 39 AC_CHECK_LIB([asprintf],[main],,[notfound=true])
37],[notfound=true]) 40],[notfound=true])
38$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) 41$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found])
39AC_LANG_POP([C++]) 42AC_LANG_POP([C++])
40 43
41nitpick=false 44nitpick=false
42AC_ARG_ENABLE([nitpicking], 45AC_ARG_ENABLE([nitpicking],
43 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 46 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
44 [ test "$enableval" = "no" || nitpick=true ] 47 [ test "$enableval" = "no" || nitpick=true ]
45) 48)
46if $nitpick ; then 49if $nitpick ; then
47 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 50 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \