-rw-r--r-- | configure.ac | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index f79983e..99d668d 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,49 +1,49 @@ | |||
1 | AC_INIT([iii], [0.2], [iii-bugs@klever.net]) | 1 | AC_INIT([iii], [0.2.1], [iii-bugs@klever.net]) |
2 | AC_CONFIG_SRCDIR([src/iiid.cc]) | 2 | AC_CONFIG_SRCDIR([src/iiid.cc]) |
3 | AC_CONFIG_HEADERS([config.h]) | 3 | AC_CONFIG_HEADERS([config.h]) |
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | 4 | AM_INIT_AUTOMAKE([dist-bzip2]) |
5 | 5 | ||
6 | AC_PROG_INSTALL | 6 | AC_PROG_INSTALL |
7 | AC_PROG_CXX | 7 | AC_PROG_CXX |
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | PKG_PROG_PKG_CONFIG | 9 | PKG_PROG_PKG_CONFIG |
10 | 10 | ||
11 | AC_HEADER_STDC | 11 | AC_HEADER_STDC |
12 | 12 | ||
13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
14 | 14 | ||
15 | PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse]) | 15 | PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse]) |
16 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) | 16 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) |
17 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) | 17 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) |
18 | if $have_uuid ; then | 18 | if $have_uuid ; then |
19 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) | 19 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) |
20 | AC_SUBST([UUID_UUID],[uuid]) | 20 | AC_SUBST([UUID_UUID],[uuid]) |
21 | fi | 21 | fi |
22 | 22 | ||
23 | AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) | 23 | AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) |
24 | test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) | 24 | test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) |
25 | 25 | ||
26 | notfound=false | 26 | notfound=false |
27 | AC_CHECK_HEADERS([archive.h],[ | 27 | AC_CHECK_HEADERS([archive.h],[ |
28 | AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) | 28 | AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) |
29 | ],[notfound=true]) | 29 | ],[notfound=true]) |
30 | $notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) | 30 | $notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) |
31 | 31 | ||
32 | notfound=false | 32 | notfound=false |
33 | AC_LANG_PUSH([C++]) | 33 | AC_LANG_PUSH([C++]) |
34 | AC_CHECK_HEADERS([autosprintf.h],[ | 34 | AC_CHECK_HEADERS([autosprintf.h],[ |
35 | AC_CHECK_LIB([asprintf],[main],,[notfound=true]) | 35 | AC_CHECK_LIB([asprintf],[main],,[notfound=true]) |
36 | ],[notfound=true]) | 36 | ],[notfound=true]) |
37 | $notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) | 37 | $notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) |
38 | AC_LANG_POP([C++]) | 38 | AC_LANG_POP([C++]) |
39 | 39 | ||
40 | nitpick=false | 40 | nitpick=false |
41 | AC_ARG_ENABLE([nitpicking], | 41 | AC_ARG_ENABLE([nitpicking], |
42 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | 42 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), |
43 | [ test "$enableval" = "no" || nitpick=true ] | 43 | [ test "$enableval" = "no" || nitpick=true ] |
44 | ) | 44 | ) |
45 | if $nitpick ; then | 45 | if $nitpick ; then |
46 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | 46 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ |
47 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | 47 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ |
48 | -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" | 48 | -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" |
49 | C_NITPICK="$CPP_NITPICK" | 49 | C_NITPICK="$CPP_NITPICK" |