summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 515d465..a719cdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,77 +1,75 @@
1AC_INIT([iii], [0.1], [iii-bugs@klever.net]) 1AC_INIT([iii], [0.1], [iii-bugs@klever.net])
2AC_CONFIG_SRCDIR([src/iiid.cc]) 2AC_CONFIG_SRCDIR([src/iiid.cc])
3AC_CONFIG_HEADERS([config.h]) 3AC_CONFIG_HEADERS([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9PKG_PROG_PKG_CONFIG 9PKG_PROG_PKG_CONFIG
10 10
11AC_HEADER_STDC 11AC_HEADER_STDC
12 12
13AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 13AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
14 14
15PKG_CHECK_MODULES([MODULES],[gsoap++ openssl libconfuse],,[ 15PKG_CHECK_MODULES([MODULES],[gsoap++ openssl libconfuse])
16 AC_MSG_ERROR([one of the build dependencies isn't satisfied])
17])
18PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 16PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
19AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 17AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
20if $have_uuid ; then 18if $have_uuid ; then
21 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 19 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
22 AC_SUBST([UUID_UUID],[uuid]) 20 AC_SUBST([UUID_UUID],[uuid])
23fi 21fi
24 22
25AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) 23AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false])
26test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) 24test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.])
27 25
28notfound=false 26notfound=false
29AC_CHECK_HEADERS([archive.h],[ 27AC_CHECK_HEADERS([archive.h],[
30 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) 28 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true])
31],[notfound=true]) 29],[notfound=true])
32$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) 30$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/])
33 31
34notfound=false 32notfound=false
35AC_LANG_PUSH([C++]) 33AC_LANG_PUSH([C++])
36AC_CHECK_HEADERS([autosprintf.h],[ 34AC_CHECK_HEADERS([autosprintf.h],[
37 AC_CHECK_LIB([asprintf],[main],,[notfound=true]) 35 AC_CHECK_LIB([asprintf],[main],,[notfound=true])
38],[notfound=true]) 36],[notfound=true])
39$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) 37$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found])
40AC_LANG_POP([C++]) 38AC_LANG_POP([C++])
41 39
42nitpick=false 40nitpick=false
43AC_ARG_ENABLE([nitpicking], 41AC_ARG_ENABLE([nitpicking],
44 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 42 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
45 [ test "$enableval" = "no" || nitpick=true ] 43 [ test "$enableval" = "no" || nitpick=true ]
46) 44)
47if $nitpick ; then 45if $nitpick ; then
48 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 46 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
49 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 47 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
50 -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" 48 -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn"
51 C_NITPICK="$CPP_NITPICK" 49 C_NITPICK="$CPP_NITPICK"
52 CXX_NITPICK="$C_NITPICK" 50 CXX_NITPICK="$C_NITPICK"
53 51
54 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 52 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
55 CFLAGS="$CFLAGS $C_NITPICK" 53 CFLAGS="$CFLAGS $C_NITPICK"
56 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 54 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
57fi 55fi
58 56
59ndebug=true 57ndebug=true
60AC_ARG_ENABLE([debug], 58AC_ARG_ENABLE([debug],
61 AC_HELP_STRING([--enable-debug],[enable debugging code]), 59 AC_HELP_STRING([--enable-debug],[enable debugging code]),
62 [ test "$enableval" = "no" || ndebug=false ] 60 [ test "$enableval" = "no" || ndebug=false ]
63) 61)
64if $ndebug ; then 62if $ndebug ; then
65 CPPFLAGS_DEBUG="-DNDEBUG" 63 CPPFLAGS_DEBUG="-DNDEBUG"
66else 64else
67 CPPFLAGS_DEBUG="-DDEBUG" 65 CPPFLAGS_DEBUG="-DDEBUG"
68fi 66fi
69AC_SUBST([CPPFLAGS_DEBUG]) 67AC_SUBST([CPPFLAGS_DEBUG])
70 68
71AC_CONFIG_FILES([ 69AC_CONFIG_FILES([
72 Makefile 70 Makefile
73 src/Makefile 71 src/Makefile
74 doc/Makefile 72 doc/Makefile
75 doc/iiid.8 73 doc/iiid.8
76]) 74])
77AC_OUTPUT 75AC_OUTPUT