-rw-r--r-- | debian/changelog | 5 | ||||
-rw-r--r-- | debian/compat | 1 | ||||
-rw-r--r-- | debian/control | 13 | ||||
l--------- | debian/copyright | 1 | ||||
-rw-r--r-- | debian/dirs | 3 | ||||
-rw-r--r-- | debian/docs | 2 | ||||
-rw-r--r-- | debian/examples | 1 | ||||
-rwxr-xr-x | debian/iii.init | 57 | ||||
-rwxr-xr-x | debian/iii.postinst | 18 | ||||
-rwxr-xr-x | debian/iii.postrm | 3 | ||||
-rwxr-xr-x | debian/iii.prerm | 4 | ||||
-rwxr-xr-x | debian/rules | 11 |
12 files changed, 119 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog new file mode 100644 index 0000000..3603e7e --- a/dev/null +++ b/debian/changelog | |||
@@ -0,0 +1,5 @@ | |||
1 | iii (0.0) unstable; urgency=low | ||
2 | |||
3 | * Initial release | ||
4 | |||
5 | -- Michael Krelin <hacker@klever.net> Sun, 08 Mar 2009 19:39:38 +0100 | ||
diff --git a/debian/compat b/debian/compat new file mode 100644 index 0000000..b8626c4 --- a/dev/null +++ b/debian/compat | |||
@@ -0,0 +1 @@ | |||
4 | |||
diff --git a/debian/control b/debian/control new file mode 100644 index 0000000..02a6138 --- a/dev/null +++ b/debian/control | |||
@@ -0,0 +1,13 @@ | |||
1 | Source: iii | ||
2 | Section: graphics | ||
3 | Priority: optional | ||
4 | Maintainer: Michael Krelin <hacker@klever.net> | ||
5 | Build-Depends: debhelper (>=7), gsoap, libssl-dev, libconfuse-dev, libarchive-dev, gettext | ||
6 | Standards-Version: 3.8.0 | ||
7 | |||
8 | Package: iii | ||
9 | Architecture: any | ||
10 | Depends: adduser, ${shlibs:Depends} | ||
11 | Description: Eye-Fi Manager implementation | ||
12 | Implementation of Eye-Fi manager service for Linux | ||
13 | |||
diff --git a/debian/copyright b/debian/copyright new file mode 120000 index 0000000..012065c --- a/dev/null +++ b/debian/copyright | |||
@@ -0,0 +1 @@ | |||
../COPYING \ No newline at end of file | |||
diff --git a/debian/dirs b/debian/dirs new file mode 100644 index 0000000..04efab3 --- a/dev/null +++ b/debian/dirs | |||
@@ -0,0 +1,3 @@ | |||
1 | /etc/iii | ||
2 | /usr/sbin | ||
3 | /usr/share/doc/iii | ||
diff --git a/debian/docs b/debian/docs new file mode 100644 index 0000000..3cc350b --- a/dev/null +++ b/debian/docs | |||
@@ -0,0 +1,2 @@ | |||
1 | AUTHORS | ||
2 | NEWS | ||
diff --git a/debian/examples b/debian/examples new file mode 100644 index 0000000..c1afd06 --- a/dev/null +++ b/debian/examples | |||
@@ -0,0 +1 @@ | |||
doc/000000000000.conf | |||
diff --git a/debian/iii.init b/debian/iii.init new file mode 100755 index 0000000..c60c25e --- a/dev/null +++ b/debian/iii.init | |||
@@ -0,0 +1,57 @@ | |||
1 | #!/bin/sh | ||
2 | ### BEGIN INIT INFO | ||
3 | # Provides: iii | ||
4 | # Required-Start: $remote_fs $network | ||
5 | # Required-Stop: $remote_fs $network | ||
6 | # Default-Start: 2 3 4 5 | ||
7 | # Default-Stop: 0 1 6 | ||
8 | # Short-Description: Start iii eye-fi card manager daemon. | ||
9 | ### END INIT INFO | ||
10 | |||
11 | set -e | ||
12 | |||
13 | PATH=/sbin:/bin:/usr/sbin:/usr/bin | ||
14 | NAME=iii | ||
15 | DAEMON=/usr/sbin/${NAME}d | ||
16 | DESC="Eye-Fi card manager daemon" | ||
17 | PIDFILE=/var/run/${NAME}d.pid | ||
18 | SCRIPTNAME=/etc/init.d/$NAME | ||
19 | USER=eyefi | ||
20 | SSD="/sbin/start-stop-daemon" | ||
21 | |||
22 | test -x $DAEMON || exit 0 | ||
23 | |||
24 | if [ -f /etc/default/$NAME ] ; then | ||
25 | . /etc/default/$NAME | ||
26 | fi | ||
27 | |||
28 | test -z "$NO_IIID" || exit 0 | ||
29 | |||
30 | . /lib/lsb/init-functions | ||
31 | |||
32 | case "$1" in | ||
33 | start) | ||
34 | log_daemon_msg "Starting $DESC" $NAME | ||
35 | $SSD --start --pidfile $PIDFILE --chuid $USER --background --make-pidfile --exec $DAEMON -- $DAEMON_OPTS | ||
36 | log_end_msg $? | ||
37 | ;; | ||
38 | stop) | ||
39 | log_daemon_msg "Stopping $DESC" $NAME | ||
40 | if $SSD --stop --oknodo --retry 30 --pidfile $PIDFILE --exec $DAEMON ; then | ||
41 | rm -f $PIDFILE | ||
42 | log_end_msg 0 | ||
43 | else | ||
44 | log_end_msg 1 | ||
45 | fi | ||
46 | ;; | ||
47 | restart|force-reload) | ||
48 | $SCRIPTNAME stop | ||
49 | $SCRIPTNAME start | ||
50 | ;; | ||
51 | *) | ||
52 | echo "Usage: $SCRIPTNAME {start|stop}" >&2 | ||
53 | exit 1 | ||
54 | ;; | ||
55 | esac | ||
56 | |||
57 | exit 0 | ||
diff --git a/debian/iii.postinst b/debian/iii.postinst new file mode 100755 index 0000000..20463a1 --- a/dev/null +++ b/debian/iii.postinst | |||
@@ -0,0 +1,18 @@ | |||
1 | #!/bin/sh | ||
2 | set -e | ||
3 | UG=eyefi | ||
4 | P=eyekindo | ||
5 | H=/var/lib/$P | ||
6 | |||
7 | if [ "$1" = configure ] ; then | ||
8 | getent group $UG >/dev/null 2>&1 || addgroup --system $UG | ||
9 | getent passwd $UG >/dev/null 2>&1 || adduser --system --home $H \ | ||
10 | --no-create-home --disabled-password --ingroup $UG $UG | ||
11 | if ! test -d $H ; then | ||
12 | mkdir -p $H | ||
13 | chown $UG:$UG $H | ||
14 | chmod 2770 $H | ||
15 | fi | ||
16 | fi | ||
17 | |||
18 | #DEBHELPER# | ||
diff --git a/debian/iii.postrm b/debian/iii.postrm new file mode 100755 index 0000000..a2c66fa --- a/dev/null +++ b/debian/iii.postrm | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | #DEBHELPER# | ||
diff --git a/debian/iii.prerm b/debian/iii.prerm new file mode 100755 index 0000000..6060c4f --- a/dev/null +++ b/debian/iii.prerm | |||
@@ -0,0 +1,4 @@ | |||
1 | #!/bin/sh | ||
2 | set -e | ||
3 | |||
4 | #DEBHELPER# | ||
diff --git a/debian/rules b/debian/rules new file mode 100755 index 0000000..86549d3 --- a/dev/null +++ b/debian/rules | |||
@@ -0,0 +1,11 @@ | |||
1 | #!/usr/bin/make -f | ||
2 | %: | ||
3 | dh $@ | ||
4 | |||
5 | build: build-stamp | ||
6 | build-stamp: | ||
7 | sh autogen.sh --version | ||
8 | dh build --before configure | ||
9 | dh_auto_configure -- --enable-debug | ||
10 | dh build --after configure | ||
11 | touch $@ | ||