summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-02-13 14:02:29 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-13 14:02:29 (UTC)
commit4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80 (patch) (unidiff)
tree47f2e6866ab812985ae9e6adbcea8bb785fa0403 /configure.ac
parentff4b919683537625f693eedf53006364d0f8444d (diff)
downloadkingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.zip
kingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.tar.gz
kingate-4fa4a0071ef9a04c02f8934b2e1d3b7628a65c80.tar.bz2
1. Support for 'plain' CGI
2. Made fastcgi support optional 3. bumped version to 0.0.1 4. doxygen documentation target 'dox' is not built for 'all' now
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 109eddf..5ae7b27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
1AC_INIT([kingate], [0.0], [kingate-bugs@klever.net]) 1AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h]) 2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_AWK 7AC_PROG_AWK
@@ -9,23 +9,28 @@ AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10AC_PROG_LIBTOOL 10AC_PROG_LIBTOOL
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_HEADERS([sys/types.h sys/stat.h]) 13AC_CHECK_HEADERS([sys/types.h sys/stat.h])
14 14
15HAVE_FCGI=false
15AC_LANG_PUSH(C++) 16AC_LANG_PUSH(C++)
16AC_CHECK_HEADERS([fcgio.h],,[ 17AC_CHECK_HEADERS([fcgio.h],[
17 exit 1 18 AC_CHECK_LIB(fcgi,FCGX_Init,[
18]) 19 LIBS="-lfcgi ${LIBS}"
19AC_CHECK_LIB(fcgi,FCGX_Init,,[ 20 AC_CHECK_LIB([fcgi++],[main],[
20 exit 1 21 LIBS="-lfcgi++ ${LIBS}"
21]) 22 HAVE_FCGI=true
22AC_CHECK_LIB([fcgi++],[main],,[ 23 ])
23 exit 1 24 ])
24]) 25])
25AC_LANG_POP(C++) 26AC_LANG_POP(C++)
27if ! ${HAVE_FCGI} ; then
28 AC_MSG_NOTICE([no FastCGI development kit found. It is highly recommnded that you get one. Meanwhile we will proceed without FastCGI support])
29fi
30AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
26 31
27AC_C_CONST 32AC_C_CONST
28 33
29AC_FUNC_MALLOC 34AC_FUNC_MALLOC
30AC_FUNC_REALLOC 35AC_FUNC_REALLOC
31 36
@@ -51,12 +56,12 @@ else
51 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 56 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
52 AM_CONDITIONAL([HAVE_DOT],[false]) 57 AM_CONDITIONAL([HAVE_DOT],[false])
53fi 58fi
54 59
55AC_CONFIG_FILES([ 60AC_CONFIG_FILES([
56 Makefile 61 Makefile
57 kingate.pc kingate-fcgi.pc 62 kingate.pc kingate-fcgi.pc kingate-plaincgi.pc
58 Doxyfile 63 Doxyfile
59 include/Makefile 64 include/Makefile
60 src/Makefile 65 src/Makefile
61]) 66])
62AC_OUTPUT 67AC_OUTPUT