summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ae7b27..b3141f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,37 +1,40 @@
1AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net]) 1AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h]) 2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_AWK 7AC_PROG_AWK
8AC_PROG_CXX 8AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10AC_PROG_LIBTOOL 10AC_PROG_LIBTOOL
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_HEADERS([sys/types.h sys/stat.h]) 13AC_CHECK_HEADERS([sys/types.h sys/stat.h])
14AC_CHECK_DECLS([environ],,,[
15 #include <unistd.h>
16])
14 17
15HAVE_FCGI=false 18HAVE_FCGI=false
16AC_LANG_PUSH(C++) 19AC_LANG_PUSH(C++)
17AC_CHECK_HEADERS([fcgio.h],[ 20AC_CHECK_HEADERS([fcgio.h],[
18 AC_CHECK_LIB(fcgi,FCGX_Init,[ 21 AC_CHECK_LIB(fcgi,FCGX_Init,[
19 LIBS="-lfcgi ${LIBS}" 22 LIBS="-lfcgi ${LIBS}"
20 AC_CHECK_LIB([fcgi++],[main],[ 23 AC_CHECK_LIB([fcgi++],[main],[
21 LIBS="-lfcgi++ ${LIBS}" 24 LIBS="-lfcgi++ ${LIBS}"
22 HAVE_FCGI=true 25 HAVE_FCGI=true
23 ]) 26 ])
24 ]) 27 ])
25]) 28])
26AC_LANG_POP(C++) 29AC_LANG_POP(C++)
27if ! ${HAVE_FCGI} ; then 30if ! ${HAVE_FCGI} ; then
28 AC_MSG_NOTICE([no FastCGI development kit found. It is highly recommnded that you get one. Meanwhile we will proceed without FastCGI support]) 31 AC_MSG_NOTICE([no FastCGI development kit found. It is highly recommnded that you get one. Meanwhile we will proceed without FastCGI support])
29fi 32fi
30AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}]) 33AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
31 34
32AC_C_CONST 35AC_C_CONST
33 36
34AC_FUNC_MALLOC 37AC_FUNC_MALLOC
35AC_FUNC_REALLOC 38AC_FUNC_REALLOC
36 39
37AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 40AC_PATH_PROG([XSLTPROC],[xsltproc],[true])