summaryrefslogtreecommitdiffabout
path: root/Makefile.am
authorMichael Krelin <hacker@klever.net>2005-01-29 19:41:34 (UTC)
committer Michael Krelin <hacker@klever.net>2005-01-29 19:41:34 (UTC)
commitee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e (patch) (unidiff)
treebe8029ce4a68870d991651927a27df8ee9d89617 /Makefile.am
parentd851b00e16839d6ec14da3a5c442be62ca868bba (diff)
downloadkonforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.zip
konforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.tar.gz
konforka-ee7ac58694c16cdd922a6eeddbe1a2eba0da7b4e.tar.bz2
initial commit.0.0
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c3fef99
--- a/dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
1SUBDIRS=include lib
2EXTRA_DIST = NEWS NEWS.xml NEWS.xsl
3
4DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig
5if HAVE_PKGCONFIG
6pkgconfigdir=@PKGCONFIG_DIR@
7pkgconfig_DATA=konforka.pc
8endif
9
10LOCAL_TARGETS=
11if HAVE_DOXYGEN
12LOCAL_TARGETS+=doxygen
13endif
14
15all-local: NEWS $(addprefix all-lota-,${LOCAL_TARGETS})
16clean-local: $(addprefix clean-lota-,${LOCAL_TARGETS})
17
18NEWS: NEWS.xsl NEWS.xml
19 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
20
21all-lota-doxygen: doxydox/built
22doxydox/built: $(wildcard ${top_srcdir}/include/konforka/*.h)
23 ${DOXYGEN}
24 touch $@
25
26clean-lota-doxygen:
27 rm -rf doxydox