summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Unidiff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am17
1 files changed, 6 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index c3fef99..aab3c4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,21 +7,16 @@ pkgconfigdir=@PKGCONFIG_DIR@
7pkgconfig_DATA=konforka.pc 7pkgconfig_DATA=konforka.pc
8endif 8endif
9 9
10LOCAL_TARGETS= 10all-local: NEWS
11if HAVE_DOXYGEN 11if HAVE_DOXYGEN
12LOCAL_TARGETS+=doxygen 12clean-local:
13 rm -rf doxydox
13endif 14endif
14 15
15all-local: NEWS $(addprefix all-lota-,${LOCAL_TARGETS})
16clean-local: $(addprefix clean-lota-,${LOCAL_TARGETS})
17
18NEWS: NEWS.xsl NEWS.xml 16NEWS: NEWS.xsl NEWS.xml
19 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml 17 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
20 18
21all-lota-doxygen: doxydox/built 19if HAVE_DOXYGEN
22doxydox/built: $(wildcard ${top_srcdir}/include/konforka/*.h) 20dox:
23 ${DOXYGEN} 21 ${DOXYGEN}
24 touch $@ 22endif
25
26clean-lota-doxygen:
27 rm -rf doxydox