summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-10-01 13:25:32 (UTC)
committer Michael Krelin <hacker@klever.net>2007-10-01 13:25:32 (UTC)
commita4c2f2e18459bc8f97860362cbde9070f51993d8 (patch) (unidiff)
treea84f9f296c64b22c0891f94a40dfbad68e5f2292 /configure.ac
parent1e329b6fcb1f6d2df9b3337c574bbcd7e66c27ea (diff)
downloadlibopkele-a4c2f2e18459bc8f97860362cbde9070f51993d8.zip
libopkele-a4c2f2e18459bc8f97860362cbde9070f51993d8.tar.gz
libopkele-a4c2f2e18459bc8f97860362cbde9070f51993d8.tar.bz2
don't be smart about pkgconfig dir
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53e22ba..4f9b6c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,26 +1,26 @@
1AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9AC_PROG_LIBTOOL 9AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG
10 11
11AC_HEADER_STDC 12AC_HEADER_STDC
12 13
13AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 14AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
14AC_WITH_PKGCONFIG
15 15
16PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 16PKG_CHECK_MODULES([OPENSSL],[openssl],,[
17 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 17 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
18]) 18])
19 19
20WANT_KONFORKA="yes" 20WANT_KONFORKA="yes"
21AC_ARG_ENABLE([konforka], 21AC_ARG_ENABLE([konforka],
22 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 22 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
23 [ 23 [
24 test "${enableval}" = "no" && WANT_KONFORKA="no" 24 test "${enableval}" = "no" && WANT_KONFORKA="no"
25 ] 25 ]
26) 26)