summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-09-11 22:44:51 (UTC)
committer Michael Krelin <hacker@klever.net>2007-09-11 22:44:51 (UTC)
commit429c48d3d08e6c2f6c385d8975f7b5bf5e67acf3 (patch) (unidiff)
tree7f314d7f129a60325bf21723ad261570d36220cd /configure.ac
parent2c6565f363527142928062afe3d3101fdbb3c550 (diff)
downloadlibopkele-429c48d3d08e6c2f6c385d8975f7b5bf5e67acf3.zip
libopkele-429c48d3d08e6c2f6c385d8975f7b5bf5e67acf3.tar.gz
libopkele-429c48d3d08e6c2f6c385d8975f7b5bf5e67acf3.tar.bz2
added support for crappy libpcre c++ bindings
Added optional support for crappy google's c++ bindings. The bindings are ridiculously googley, so I think, taking into account the amount of pcre involved, I'll soon drop requirement for any bindings and will use libpcre directly. Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac49
1 files changed, 43 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 2094273..00c6bc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,15 +52,52 @@ fi
52LIBCURL_CHECK_CONFIG(,,,[ 52LIBCURL_CHECK_CONFIG(,,,[
53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
54]) 54])
55AC_WITH_PCRE([ 55
56 AC_WITH_PCREPP(,[ 56want_pcre_impl=""
57 AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) 57AC_ARG_WITH([pcre-bindings],
58 ]) 58 AC_HELP_STRING([--with-pcre-bindings=(pcrepp|none|libpcrecpp)],[Specify which pcre c++ bindings to use. 'pcrepp' stands for quite sensible library, found at http://www.daemon.de/PCRE/, 'libcrecpp' makes use of crappy bindings by google and 'none' disables internal implementation of OP discovery]),
59 ],[ 59 [
60 AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) 60 case "$withval" in
61 pcrepp) want_pcre_impl="pcrepp" ;;
62 libpcrecpp) want_pcre_impl="libpcrecpp" ;;
63 none) want_pcre_impl="none";;
64 *) AC_MSG_ERROR([I'm not sure I understand what do you want for a pcre c++ bindings]) ;;
65 esac
61 ] 66 ]
62) 67)
63 68
69found_pcre_impl=""
70
71if test -z "$want_pcre_impl" -o "$want_pcre_impl" = "pcrepp" ; then
72 AC_WITH_PCRE([
73 AC_WITH_PCREPP([
74 found_pcre_impl=pcrepp
75 ])
76 ],[
77 AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/])
78 ]
79 )
80 test "$want_pcre_impl,$found_pcre_impl" = "pcrepp," && AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE])
81fi
82
83if test "$found_pcre_impl,$want_pcre_impl" = "," -o "$want_pcre_impl" = "libpcrecpp" ; then
84 test -z "$want_pcre_impl" || AC_MSG_NOTICE([You want to use crappy libpcre c++ bindings])
85 PKG_CHECK_MODULES([LIBPCRECPP],[libpcrecpp],[
86 found_pcre_impl=libpcrecpp
87 CXXFLAGS="$CXXFLAGS $LIBPCRECPP_CFLAGS"
88 LIBS="$LIBS $LIBPCRECPP_LIBS"
89 ],[
90 test -z "$want_pcre_impl" || AC_MSG_ERROR([no libpcre c++ bindings found. why would you want it if you don't have it installed?])
91 ]
92 )
93fi
94test "$want_pcre_impl,$found_pcre_impl" = "," && AC_MSG_ERROR([no pcre c++ bindings found, use --with-pcre-bindings=none to disable code that makes use of it])
95
96case "$found_pcre_impl" in
97 pcrepp) AC_DEFINE([USE_PCREPP],,[defined if pcre++ is to be used]) ;;
98 libpcrecpp) AC_DEFINE([USE_LIBPCRECPP],,[defined if crappy google bindings are to be used]) ;;
99esac
100
64curl_ssl_verify_host="true" 101curl_ssl_verify_host="true"
65AC_ARG_ENABLE([ssl-verify-host], 102AC_ARG_ENABLE([ssl-verify-host],
66 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 103 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),