summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2008-01-20 20:57:20 (UTC)
committer Michael Krelin <hacker@klever.net>2008-01-20 20:57:20 (UTC)
commite87c920413b8443e83a57b7f1edf72b0cdb8b6c1 (patch) (unidiff)
tree4c6eef9b79985c4fdb45faca6644647b582d1a29 /configure.ac
parent2f82a7acabcb00c6785151f9aca3d4270f3914b7 (diff)
downloadlibopkele-e87c920413b8443e83a57b7f1edf72b0cdb8b6c1.zip
libopkele-e87c920413b8443e83a57b7f1edf72b0cdb8b6c1.tar.gz
libopkele-e87c920413b8443e83a57b7f1edf72b0cdb8b6c1.tar.bz2
merging the private rewrite branch, configure.ac
* bump version. two leading components are getting in sync with OpenID protocol version now, which means it's going to be 2.0 by the time I finish 2.0 support. * add checks for some optional gcc features. * check for optional dependencies needed to build test RP CGI, namely - sqlite3, kingate, libuuid. * change XRI resolver proxy to non-beta https.
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac48
1 files changed, 45 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c28141c..a49177f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1AC_INIT([libopkele], [0.4], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [1.1.99.0], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
@@ -61,6 +61,41 @@ esac
61AC_SUBST([OPKELE_TR1_MEM_NS]) 61AC_SUBST([OPKELE_TR1_MEM_NS])
62AC_SUBST([OPKELE_TR1_MEM_HEADER]) 62AC_SUBST([OPKELE_TR1_MEM_HEADER])
63 63
64AC_MSG_CHECKING([for deprecated attribute support])
65AC_COMPILE_IFELSE([
66 int __attribute__((deprecated)) deprecated_function();
67 ],[
68 AC_MSG_RESULT([yes])
69 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
70 ],[
71 AC_MSG_RESULT([no])
72 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
73 ]
74)
75
76AC_LANG_PUSH([C++])
77AC_MSG_CHECKING([for abi::__cxa_demangle])
78AC_COMPILE_IFELSE([
79 #include <typeinfo>
80 using namespace std;
81 #include <cxxabi.h>
82 int main(int c,char **v) {
83 int dstat;
84 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
85 return 0;
86 }
87 ],[
88 AC_MSG_RESULT([yes])
89 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
90 ],[
91 AC_MSG_RESULT([no])
92 ]
93)
94AC_LANG_POP([C++])
95
96
97
98
64PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 99PKG_CHECK_MODULES([OPENSSL],[openssl],,[
65 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 100 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
66]) 101])
@@ -137,6 +172,13 @@ else
137 ]) 172 ])
138fi 173fi
139 174
175PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
176AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
177PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
178AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
179PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
180AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
181
140curl_ssl_verify_host="true" 182curl_ssl_verify_host="true"
141AC_ARG_ENABLE([ssl-verify-host], 183AC_ARG_ENABLE([ssl-verify-host],
142 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 184 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
@@ -190,10 +232,10 @@ else
190fi 232fi
191AC_SUBST([CPPFLAGS_DEBUG]) 233AC_SUBST([CPPFLAGS_DEBUG])
192 234
193xri_proxy_url="http://beta.xri.net/" 235xri_proxy_url="https://xri.net/"
194AC_MSG_CHECKING([for XRI resolver proxy]) 236AC_MSG_CHECKING([for XRI resolver proxy])
195AC_ARG_ENABLE([xri-proxy], 237AC_ARG_ENABLE([xri-proxy],
196 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is http://xr_proxy_url]), 238 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]),
197 [ xri_proxy_url="$withval" ] 239 [ xri_proxy_url="$withval" ]
198) 240)
199AC_MSG_RESULT([$xri_proxy_url]) 241AC_MSG_RESULT([$xri_proxy_url])