summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
authorMichael Krelin <hacker@klever.net>2008-03-04 21:30:28 (UTC)
committer Michael Krelin <hacker@klever.net>2008-03-04 21:34:13 (UTC)
commit748a2a29a5667f372bf355ed737208a952ff79f0 (patch) (unidiff)
tree1739374b0cb82ad2758af8feddbef1b6a6bf5eee /test/Makefile.am
parent1e3ed01c149aaeed5a64aacff218a5486128fc92 (diff)
downloadlibopkele-748a2a29a5667f372bf355ed737208a952ff79f0.zip
libopkele-748a2a29a5667f372bf355ed737208a952ff79f0.tar.gz
libopkele-748a2a29a5667f372bf355ed737208a952ff79f0.tar.bz2
comitting perliminary oauth consumer api
* added the said consumer api and test consumer * added trivial map-based opkele::fields_t container * added UUID flags to libopkele.la build * fixed query_append so that it doesn't append '?' in absence of query parameters * added basic_fields::from_query() Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'test/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--test/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8fedf48..f0c0ea8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,51 +1,54 @@
1noinst_PROGRAMS = test idiscover RP.cgi OP.cgi 1noinst_PROGRAMS = test idiscover RP.cgi OP.cgi test-oauth-consumer
2 2
3AM_CPPFLAGS=${CPPFLAGS_DEBUG} 3AM_CPPFLAGS=${CPPFLAGS_DEBUG}
4DEFAULT_INCLUDES = -I${top_builddir} 4DEFAULT_INCLUDES = -I${top_builddir}
5INCLUDES = -I${top_srcdir}/test/ -I${top_builddir}/include/ -I${top_srcdir}/include/ ${KONFORKA_CFLAGS} ${LIBCURL_CPPFLAGS} 5INCLUDES = -I${top_srcdir}/test/ -I${top_builddir}/include/ -I${top_srcdir}/include/ ${KONFORKA_CFLAGS} ${LIBCURL_CPPFLAGS}
6 6
7test_SOURCES = test.cc 7test_SOURCES = test.cc
8test_LDADD = ${top_builddir}/lib/libopkele.la 8test_LDADD = ${top_builddir}/lib/libopkele.la
9 9
10EXTRA_DIST= \ 10EXTRA_DIST= \
11 sqlite.h kingate_openid_message.h \ 11 sqlite.h kingate_openid_message.h \
12 RP-db.sql OP-db.sql 12 RP-db.sql OP-db.sql
13 13
14idiscover_SOURCES = idiscover.cc 14idiscover_SOURCES = idiscover.cc
15idiscover_LDADD = ${top_builddir}/lib/libopkele.la 15idiscover_LDADD = ${top_builddir}/lib/libopkele.la
16 16
17test_oauth_consumer_SOURCES = test-oauth-consumer.cc
18test_oauth_consumer_LDADD = ${top_builddir}/lib/libopkele.la
19
17if HAVE_SQLITE3 20if HAVE_SQLITE3
18if HAVE_KINGATE 21if HAVE_UUID
19if HAVE_UUID 22if HAVE_KINGATE
20 23
21RP_cgi_SOURCES = RP.cc 24RP_cgi_SOURCES = RP.cc
22nodist_RP_cgi_SOURCES = RP-db.cc 25nodist_RP_cgi_SOURCES = RP-db.cc
23RP_cgi_LDADD = ${top_builddir}/lib/libopkele.la \ 26RP_cgi_LDADD = ${top_builddir}/lib/libopkele.la \
24 ${SQLITE3_LIBS} ${KINGATE_LIBS} ${UUID_LIBS} 27 ${SQLITE3_LIBS} ${KINGATE_LIBS}
25RP_cgi_CFLAGS = ${SQLITE3_CFLAGS} ${KINGATE_CFLAGS} ${UUID_CFLAGS} 28RP_cgi_CFLAGS = ${SQLITE3_CFLAGS} ${KINGATE_CFLAGS}
26 29
27RP-db.cc: RP-db.sql 30RP-db.cc: RP-db.sql
28 ( \ 31 ( \
29 echo 'const char * __RP_db_bootstrap = ' && \ 32 echo 'const char * __RP_db_bootstrap = ' && \
30 sed -e 's/^/"/' -e 's/$$/"/' $< && \ 33 sed -e 's/^/"/' -e 's/$$/"/' $< && \
31 echo ';' \ 34 echo ';' \
32 ) >$@ 35 ) >$@
33 36
34OP_cgi_SOURCES = OP.cc 37OP_cgi_SOURCES = OP.cc
35nodist_OP_cgi_SOURCES = OP-db.cc 38nodist_OP_cgi_SOURCES = OP-db.cc
36OP_cgi_LDADD = ${RP_cgi_LDADD} 39OP_cgi_LDADD = ${RP_cgi_LDADD}
37OP_cgi_CFLAGS = ${RP_cgi_CFLAGS} 40OP_cgi_CFLAGS = ${RP_cgi_CFLAGS}
38 41
39OP-db.cc: OP-db.sql 42OP-db.cc: OP-db.sql
40 ( \ 43 ( \
41 echo 'const char * __OP_db_bootstrap = ' && \ 44 echo 'const char * __OP_db_bootstrap = ' && \
42 sed -e 's/^/"/' -e 's/$$/"/' $< && \ 45 sed -e 's/^/"/' -e 's/$$/"/' $< && \
43 echo ';' \ 46 echo ';' \
44 ) >$@ 47 ) >$@
45 48
46clean-local: 49clean-local:
47 rm -f RP-db.cc OP-db.cc 50 rm -f RP-db.cc OP-db.cc
48 51
49endif #HAVE_UUID 52endif #HAVE_KINGATE
50endif #HAVE_KINGATE 53endif #HAVE_UUID
51endif #HAVE_SQLITE3 54endif #HAVE_SQLITE3