author | Michael Krelin <hacker@klever.net> | 2007-12-02 21:48:18 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2007-12-02 21:51:08 (UTC) |
commit | 262f1579f0a9138a01f06afea06d00155cefd4b5 (patch) (unidiff) | |
tree | fb4db0ee7b679a1957c63abbe6f6af1d2fa82531 /test/Makefile.am | |
parent | 73d98f3652b498b9a74b183bef395714c7d73fda (diff) | |
download | libopkele-262f1579f0a9138a01f06afea06d00155cefd4b5.zip libopkele-262f1579f0a9138a01f06afea06d00155cefd4b5.tar.gz libopkele-262f1579f0a9138a01f06afea06d00155cefd4b5.tar.bz2 |
first cut on XRI resolver
This commit adds openid service resolver that does discovery using XRI (proxy
only), Yadis protocol and html-based discovery. It uses expat as xml parsing
engine, which makes it a bit more strict about html it receives, but I think
failing to discover links in *severely* broken html is better than
misdetecting links, hidden in comments or such.
This is highly experimental code and needs more thoughts and testing.
Thanks everyone pushing me towards this development. Namely Joseph, John,
Gen.
Signed-off-by: Michael Krelin <hacker@klever.net>
-rw-r--r-- | test/Makefile.am | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am index 4b78087..5aa87b3 100644 --- a/test/Makefile.am +++ b/test/Makefile.am | |||
@@ -1,12 +1,15 @@ | |||
1 | noinst_PROGRAMS = test | 1 | noinst_PROGRAMS = test openid_resolve |
2 | 2 | ||
3 | DEFAULT_INCLUDES = -I${top_builddir} | 3 | DEFAULT_INCLUDES = -I${top_builddir} |
4 | INCLUDES = -I${top_srcdir}/include/ ${KONFORKA_CFLAGS} | 4 | INCLUDES = -I${top_srcdir}/include/ ${KONFORKA_CFLAGS} |
5 | 5 | ||
6 | test_SOURCES = test.cc | 6 | test_SOURCES = test.cc |
7 | test_LDADD = ${top_builddir}/lib/libopkele.la | 7 | test_LDADD = ${top_builddir}/lib/libopkele.la |
8 | 8 | ||
9 | EXTRA_DIST=$(addsuffix .html,$(addprefix html/, \ | 9 | EXTRA_DIST=$(addsuffix .html,$(addprefix html/, \ |
10 | empty head-in-body hkn-delegate hkn-server hkn in-body \ | 10 | empty head-in-body hkn-delegate hkn-server hkn in-body \ |
11 | unclosed-head spaced-links spaced-link-attrs 2rels \ | 11 | unclosed-head spaced-links spaced-link-attrs 2rels \ |
12 | )) | 12 | )) |
13 | |||
14 | openid_resolve_SOURCES = openid_resolve.cc | ||
15 | openid_resolve_LDADD = ${top_builddir}/lib/libopkele.la | ||