summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
authorMichael Krelin <hacker@klever.net>2008-03-04 21:30:28 (UTC)
committer Michael Krelin <hacker@klever.net>2008-03-04 21:34:13 (UTC)
commit748a2a29a5667f372bf355ed737208a952ff79f0 (patch) (side-by-side diff)
tree1739374b0cb82ad2758af8feddbef1b6a6bf5eee /test/Makefile.am
parent1e3ed01c149aaeed5a64aacff218a5486128fc92 (diff)
downloadlibopkele-748a2a29a5667f372bf355ed737208a952ff79f0.zip
libopkele-748a2a29a5667f372bf355ed737208a952ff79f0.tar.gz
libopkele-748a2a29a5667f372bf355ed737208a952ff79f0.tar.bz2
comitting perliminary oauth consumer api
* added the said consumer api and test consumer * added trivial map-based opkele::fields_t container * added UUID flags to libopkele.la build * fixed query_append so that it doesn't append '?' in absence of query parameters * added basic_fields::from_query() Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'test/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--test/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8fedf48..f0c0ea8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = test idiscover RP.cgi OP.cgi
+noinst_PROGRAMS = test idiscover RP.cgi OP.cgi test-oauth-consumer
AM_CPPFLAGS=${CPPFLAGS_DEBUG}
DEFAULT_INCLUDES = -I${top_builddir}
@@ -14,15 +14,18 @@ EXTRA_DIST= \
idiscover_SOURCES = idiscover.cc
idiscover_LDADD = ${top_builddir}/lib/libopkele.la
+test_oauth_consumer_SOURCES = test-oauth-consumer.cc
+test_oauth_consumer_LDADD = ${top_builddir}/lib/libopkele.la
+
if HAVE_SQLITE3
-if HAVE_KINGATE
-if HAVE_UUID
+if HAVE_UUID
+if HAVE_KINGATE
RP_cgi_SOURCES = RP.cc
nodist_RP_cgi_SOURCES = RP-db.cc
RP_cgi_LDADD = ${top_builddir}/lib/libopkele.la \
- ${SQLITE3_LIBS} ${KINGATE_LIBS} ${UUID_LIBS}
-RP_cgi_CFLAGS = ${SQLITE3_CFLAGS} ${KINGATE_CFLAGS} ${UUID_CFLAGS}
+ ${SQLITE3_LIBS} ${KINGATE_LIBS}
+RP_cgi_CFLAGS = ${SQLITE3_CFLAGS} ${KINGATE_CFLAGS}
RP-db.cc: RP-db.sql
( \
@@ -46,6 +49,6 @@ OP-db.cc: OP-db.sql
clean-local:
rm -f RP-db.cc OP-db.cc
-endif #HAVE_UUID
-endif #HAVE_KINGATE
+endif #HAVE_KINGATE
+endif #HAVE_UUID
endif #HAVE_SQLITE3