summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4f9b6c2..68872d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,5 +55,10 @@ LIBCURL_CHECK_CONFIG(,,,[
-PKG_CHECK_MODULES([PCRE],[libpcre],,[
- AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
-])
+if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
+ AC_SUBST([PCRE_CFLAGS])
+ AC_SUBST([PCRE_LIBS])
+else
+ PKG_CHECK_MODULES([PCRE],[libpcre],,[
+ AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
+ ])
+fi