summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a49177f..0aa1272 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,24 +169,28 @@ if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
169else 169else
170 PKG_CHECK_MODULES([PCRE],[libpcre],,[ 170 PKG_CHECK_MODULES([PCRE],[libpcre],,[
171 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 171 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
172 ]) 172 ])
173fi 173fi
174 174
175PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 175PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
176AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 176AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
177PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 177PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
178AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 178AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
179PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 179PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
180AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 180AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
181if $have_uuid ; then
182 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
183 AC_SUBST([UUID_UUID],[uuid])
184fi
181 185
182curl_ssl_verify_host="true" 186curl_ssl_verify_host="true"
183AC_ARG_ENABLE([ssl-verify-host], 187AC_ARG_ENABLE([ssl-verify-host],
184 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 188 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
185 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 189 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
186) 190)
187${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 191${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
188 192
189curl_ssl_verify_peer="true" 193curl_ssl_verify_peer="true"
190AC_ARG_ENABLE([ssl-verify-peer], 194AC_ARG_ENABLE([ssl-verify-peer],
191 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 195 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
192 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 196 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]