summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5fb6bec..7fa2f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,34 +157,24 @@ AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
TIDY_LIBS=-ltidy
TIDY_CFLAGS=
AC_SUBST([TIDY_LIBS])
AC_SUBST([TIDY_CFLAGS])
],[
AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
])
],[
test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
&& AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
])
-if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
- AC_SUBST([PCRE_CFLAGS])
- AC_SUBST([PCRE_LIBS])
- :
-else
- PKG_CHECK_MODULES([PCRE],[libpcre],,[
- AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
- ])
-fi
-
PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
if $have_uuid ; then
AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
AC_SUBST([UUID_UUID],[uuid])
fi
curl_ssl_verify_host="true"