summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e636253..606e644 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,207 +1,208 @@
1AC_INIT([libopkele], [2.0.4], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.4], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d]) 4AC_CONFIG_MACRO_DIR([aclocal.d])
5AC_CONFIG_AUX_DIR([aux.d]) 5AC_CONFIG_AUX_DIR([aux.d])
6AM_INIT_AUTOMAKE([dist-bzip2]) 6AM_INIT_AUTOMAKE([dist-bzip2])
7 7
8AC_PROG_INSTALL 8AC_PROG_INSTALL
9AC_PROG_CXX 9AC_PROG_CXX
10AC_PROG_CC 10AC_PROG_CC
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12PKG_PROG_PKG_CONFIG 12PKG_PROG_PKG_CONFIG
13 13
14AC_HEADER_STDC 14AC_HEADER_STDC
15AC_CHECK_FUNCS([timegm]) 15AC_CHECK_FUNCS([timegm])
16AC_CHECK_HEADERS([ext/algorithm.h])
16 17
17AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 18AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
18 19
19AC_MSG_CHECKING([for source tree version]) 20AC_MSG_CHECKING([for source tree version])
20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 21if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 22 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 23 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 24 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 25 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
25else 26else
26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 27 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
27fi 28fi
28AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 29AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
29AC_SUBST([PACKAGE_SRC_VERSION]) 30AC_SUBST([PACKAGE_SRC_VERSION])
30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 31AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
31 32
32tr1_mem_std="false" 33tr1_mem_std="false"
33tr1_mem_boost="false" 34tr1_mem_boost="false"
34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 35AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 36AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
36tr1_mem="" 37tr1_mem=""
37AC_ARG_WITH([tr1-memory], 38AC_ARG_WITH([tr1-memory],
38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 39 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
39 [ tr1_mem="$withval" ] 40 [ tr1_mem="$withval" ]
40) 41)
41AC_MSG_CHECKING([for tr1/memory implementation to use]) 42AC_MSG_CHECKING([for tr1/memory implementation to use])
42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 43test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 44test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
44if test -z "$tr1_mem" ; then 45if test -z "$tr1_mem" ; then
45 AC_MSG_RESULT([none found]) 46 AC_MSG_RESULT([none found])
46else 47else
47 AC_MSG_RESULT([$tr1_mem]) 48 AC_MSG_RESULT([$tr1_mem])
48fi 49fi
49case "$tr1_mem" in 50case "$tr1_mem" in
50 std) 51 std)
51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 52 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
52 OPKELE_TR1_MEM_NS=std::tr1 53 OPKELE_TR1_MEM_NS=std::tr1
53 OPKELE_TR1_MEM_HEADER=tr1/memory 54 OPKELE_TR1_MEM_HEADER=tr1/memory
54 ;; 55 ;;
55 boost) 56 boost)
56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 57 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
57 OPKELE_TR1_MEM_NS=boost 58 OPKELE_TR1_MEM_NS=boost
58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 59 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
59 ;; 60 ;;
60 *) 61 *)
61 AC_MSG_ERROR([no shared_ptr<> implementation found]) 62 AC_MSG_ERROR([no shared_ptr<> implementation found])
62 ;; 63 ;;
63esac 64esac
64AC_SUBST([OPKELE_TR1_MEM_NS]) 65AC_SUBST([OPKELE_TR1_MEM_NS])
65AC_SUBST([OPKELE_TR1_MEM_HEADER]) 66AC_SUBST([OPKELE_TR1_MEM_HEADER])
66 67
67AC_MSG_CHECKING([for deprecated attribute support]) 68AC_MSG_CHECKING([for deprecated attribute support])
68AC_COMPILE_IFELSE([ 69AC_COMPILE_IFELSE([
69 int __attribute__((deprecated)) deprecated_function(); 70 int __attribute__((deprecated)) deprecated_function();
70 ],[ 71 ],[
71 AC_MSG_RESULT([yes]) 72 AC_MSG_RESULT([yes])
72 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 73 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
73 ],[ 74 ],[
74 AC_MSG_RESULT([no]) 75 AC_MSG_RESULT([no])
75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 76 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
76 ] 77 ]
77) 78)
78 79
79AC_LANG_PUSH([C++]) 80AC_LANG_PUSH([C++])
80AC_MSG_CHECKING([for abi::__cxa_demangle]) 81AC_MSG_CHECKING([for abi::__cxa_demangle])
81AC_COMPILE_IFELSE([ 82AC_COMPILE_IFELSE([
82 #include <typeinfo> 83 #include <typeinfo>
83 using namespace std; 84 using namespace std;
84 #include <cxxabi.h> 85 #include <cxxabi.h>
85 int main(int c,char **v) { 86 int main(int c,char **v) {
86 int dstat; 87 int dstat;
87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 88 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
88 return 0; 89 return 0;
89 } 90 }
90 ],[ 91 ],[
91 AC_MSG_RESULT([yes]) 92 AC_MSG_RESULT([yes])
92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 93 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
93 ],[ 94 ],[
94 AC_MSG_RESULT([no]) 95 AC_MSG_RESULT([no])
95 ] 96 ]
96) 97)
97AC_LANG_POP([C++]) 98AC_LANG_POP([C++])
98 99
99 100
100 101
101 102
102PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 103PKG_CHECK_MODULES([OPENSSL],[openssl],,[
103 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 104 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
104]) 105])
105 106
106WANT_KONFORKA="yes" 107WANT_KONFORKA="yes"
107AC_ARG_ENABLE([konforka], 108AC_ARG_ENABLE([konforka],
108 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 109 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
109 [ 110 [
110 test "${enableval}" = "no" && WANT_KONFORKA="no" 111 test "${enableval}" = "no" && WANT_KONFORKA="no"
111 ] 112 ]
112) 113)
113if test "${WANT_KONFORKA}" = "yes" ; then 114if test "${WANT_KONFORKA}" = "yes" ; then
114 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 115 PKG_CHECK_MODULES([KONFORKA],[konforka],[
115 AC_SUBST([KONFORKA_CFLAGS]) 116 AC_SUBST([KONFORKA_CFLAGS])
116 AC_SUBST([KONFORKA_LIBS]) 117 AC_SUBST([KONFORKA_LIBS])
117 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 118 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
118 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 119 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
119 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 120 AC_SUBST([KONFORKA_KONFORKA],[konforka])
120 ],[true]) 121 ],[true])
121fi 122fi
122 123
123WANT_DOXYGEN="yes" 124WANT_DOXYGEN="yes"
124AC_ARG_ENABLE([doxygen], 125AC_ARG_ENABLE([doxygen],
125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 126 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
126 [ 127 [
127 test "${enableval}" = "no" && WANT_DOXYGEN="no" 128 test "${enableval}" = "no" && WANT_DOXYGEN="no"
128 ] 129 ]
129) 130)
130if test "${WANT_DOXYGEN}" = "yes" ; then 131if test "${WANT_DOXYGEN}" = "yes" ; then
131 AC_WITH_DOXYGEN 132 AC_WITH_DOXYGEN
132 AC_WITH_DOT 133 AC_WITH_DOT
133else 134else
134 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 135 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
135 AM_CONDITIONAL([HAVE_DOT],[false]) 136 AM_CONDITIONAL([HAVE_DOT],[false])
136fi 137fi
137 138
138LIBCURL_CHECK_CONFIG(,,,[ 139LIBCURL_CHECK_CONFIG(,,,[
139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 140 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
140]) 141])
141 142
142AC_CHECK_HEADER([expat.h],[ 143AC_CHECK_HEADER([expat.h],[
143 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 144 AC_CHECK_LIB([expat],[XML_ParserCreate],[
144 EXPAT_LIBS=-lexpat 145 EXPAT_LIBS=-lexpat
145 EXPAT_CFLAGS= 146 EXPAT_CFLAGS=
146 AC_SUBST([EXPAT_LIBS]) 147 AC_SUBST([EXPAT_LIBS])
147 AC_SUBST([EXPAT_CFLAGS]) 148 AC_SUBST([EXPAT_CFLAGS])
148 ],[ 149 ],[
149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 150 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
150 ]) 151 ])
151],[ 152],[
152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 153 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
153]) 154])
154 155
155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 156AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 157 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[
157 TIDY_LIBS=-ltidy 158 TIDY_LIBS=-ltidy
158 TIDY_CFLAGS= 159 TIDY_CFLAGS=
159 AC_SUBST([TIDY_LIBS]) 160 AC_SUBST([TIDY_LIBS])
160 AC_SUBST([TIDY_CFLAGS]) 161 AC_SUBST([TIDY_CFLAGS])
161 ],[ 162 ],[
162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 163 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
163 ]) 164 ])
164],[ 165],[
165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \ 166 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 167 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
167]) 168])
168 169
169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 170PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 171AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 172PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 173AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 174PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
174AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 175AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
175if $have_uuid ; then 176if $have_uuid ; then
176 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 177 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
177 AC_SUBST([UUID_UUID],[uuid]) 178 AC_SUBST([UUID_UUID],[uuid])
178fi 179fi
179 180
180curl_ssl_verify_host="true" 181curl_ssl_verify_host="true"
181AC_ARG_ENABLE([ssl-verify-host], 182AC_ARG_ENABLE([ssl-verify-host],
182 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 183 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
183 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 184 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
184) 185)
185${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 186${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
186 187
187curl_ssl_verify_peer="true" 188curl_ssl_verify_peer="true"
188AC_ARG_ENABLE([ssl-verify-peer], 189AC_ARG_ENABLE([ssl-verify-peer],
189 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 190 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
190 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 191 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
191) 192)
192${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 193${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
193 194
194postels_law=true 195postels_law=true
195AC_ARG_ENABLE([postels-law], 196AC_ARG_ENABLE([postels-law],
196 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 197 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
197 [ test "${enableval}" = "no" && postels_law=false ] 198 [ test "${enableval}" = "no" && postels_law=false ]
198) 199)
199$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 200$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
200 201
201AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 202AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
202 203
203nitpick=false 204nitpick=false
204AC_ARG_ENABLE([nitpicking], 205AC_ARG_ENABLE([nitpicking],
205 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 206 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
206 [ test "$enableval" = "no" || nitpick=true ] 207 [ test "$enableval" = "no" || nitpick=true ]
207) 208)