summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51bacd5..5772ead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,48 +93,61 @@ if test "${WANT_DOXYGEN}" = "yes" ; then
93 AC_WITH_DOXYGEN 93 AC_WITH_DOXYGEN
94 AC_WITH_DOT 94 AC_WITH_DOT
95else 95else
96 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 96 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
97 AM_CONDITIONAL([HAVE_DOT],[false]) 97 AM_CONDITIONAL([HAVE_DOT],[false])
98fi 98fi
99 99
100LIBCURL_CHECK_CONFIG(,,,[ 100LIBCURL_CHECK_CONFIG(,,,[
101 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 101 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
102]) 102])
103 103
104AC_CHECK_HEADER([expat.h],[ 104AC_CHECK_HEADER([expat.h],[
105 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 105 AC_CHECK_LIB([expat],[XML_ParserCreate],[
106 EXPAT_LIBS=-lexpat 106 EXPAT_LIBS=-lexpat
107 EXPAT_CFLAGS= 107 EXPAT_CFLAGS=
108 AC_SUBST([EXPAT_LIBS]) 108 AC_SUBST([EXPAT_LIBS])
109 AC_SUBST([EXPAT_CFLAGS]) 109 AC_SUBST([EXPAT_CFLAGS])
110 ],[ 110 ],[
111 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 111 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
112 ]) 112 ])
113],[ 113],[
114 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 114 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
115]) 115])
116 116
117AC_CHECK_HEADER([tidy.h],[
118 AC_CHECK_LIB([tidy],[tidyParseBuffer],[
119 TIDY_LIBS=-ltidy
120 TIDY_CFLAGS=
121 AC_SUBST([TIDY_LIBS])
122 AC_SUBST([TIDY_CFLAGS])
123 ],[
124 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
125 ])
126],[
127 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
128])
129
117if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 130if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
118 AC_SUBST([PCRE_CFLAGS]) 131 AC_SUBST([PCRE_CFLAGS])
119 AC_SUBST([PCRE_LIBS]) 132 AC_SUBST([PCRE_LIBS])
120 : 133 :
121else 134else
122 PKG_CHECK_MODULES([PCRE],[libpcre],,[ 135 PKG_CHECK_MODULES([PCRE],[libpcre],,[
123 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 136 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
124 ]) 137 ])
125fi 138fi
126 139
127curl_ssl_verify_host="true" 140curl_ssl_verify_host="true"
128AC_ARG_ENABLE([ssl-verify-host], 141AC_ARG_ENABLE([ssl-verify-host],
129 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 142 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
130 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 143 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
131) 144)
132${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 145${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
133 146
134curl_ssl_verify_peer="true" 147curl_ssl_verify_peer="true"
135AC_ARG_ENABLE([ssl-verify-peer], 148AC_ARG_ENABLE([ssl-verify-peer],
136 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 149 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
137 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 150 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
138) 151)
139${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 152${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
140 153