summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48a5efb..2b94b41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,64 +37,77 @@ AC_ARG_ENABLE([konforka],
37 test "${enableval}" = "no" && WANT_KONFORKA="no" 37 test "${enableval}" = "no" && WANT_KONFORKA="no"
38 ] 38 ]
39) 39)
40if test "${WANT_KONFORKA}" = "yes" ; then 40if test "${WANT_KONFORKA}" = "yes" ; then
41 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 41 PKG_CHECK_MODULES([KONFORKA],[konforka],[
42 AC_SUBST([KONFORKA_CFLAGS]) 42 AC_SUBST([KONFORKA_CFLAGS])
43 AC_SUBST([KONFORKA_LIBS]) 43 AC_SUBST([KONFORKA_LIBS])
44 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 44 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
45 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 45 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
46 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 46 AC_SUBST([KONFORKA_KONFORKA],[konforka])
47 ],[true]) 47 ],[true])
48fi 48fi
49 49
50WANT_DOXYGEN="yes" 50WANT_DOXYGEN="yes"
51AC_ARG_ENABLE([doxygen], 51AC_ARG_ENABLE([doxygen],
52 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 52 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
53 [ 53 [
54 test "${enableval}" = "no" && WANT_DOXYGEN="no" 54 test "${enableval}" = "no" && WANT_DOXYGEN="no"
55 ] 55 ]
56) 56)
57if test "${WANT_DOXYGEN}" = "yes" ; then 57if test "${WANT_DOXYGEN}" = "yes" ; then
58 AC_WITH_DOXYGEN 58 AC_WITH_DOXYGEN
59 AC_WITH_DOT 59 AC_WITH_DOT
60else 60else
61 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 61 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
62 AM_CONDITIONAL([HAVE_DOT],[false]) 62 AM_CONDITIONAL([HAVE_DOT],[false])
63fi 63fi
64 64
65LIBCURL_CHECK_CONFIG(,,,[ 65LIBCURL_CHECK_CONFIG(,,,[
66 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 66 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
67]) 67])
68 68
69AC_CHECK_HEADER([expat.h],[
70 AC_CHECK_LIB([expat],[XML_ParserCreate],[
71 EXPAT_LIBS=-lexpat
72 EXPAT_CFLAGS=
73 AC_SUBST([EXPAT_LIBS])
74 AC_SUBST([EXPAT_CFLAGS])
75 ],[
76 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
77 ])
78],[
79 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
80])
81
69if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 82if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
70 AC_SUBST([PCRE_CFLAGS]) 83 AC_SUBST([PCRE_CFLAGS])
71 AC_SUBST([PCRE_LIBS]) 84 AC_SUBST([PCRE_LIBS])
72 : 85 :
73else 86else
74 PKG_CHECK_MODULES([PCRE],[libpcre],,[ 87 PKG_CHECK_MODULES([PCRE],[libpcre],,[
75 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 88 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
76 ]) 89 ])
77fi 90fi
78 91
79curl_ssl_verify_host="true" 92curl_ssl_verify_host="true"
80AC_ARG_ENABLE([ssl-verify-host], 93AC_ARG_ENABLE([ssl-verify-host],
81 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 94 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
82 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 95 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
83) 96)
84${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 97${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
85 98
86curl_ssl_verify_peer="true" 99curl_ssl_verify_peer="true"
87AC_ARG_ENABLE([ssl-verify-peer], 100AC_ARG_ENABLE([ssl-verify-peer],
88 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 101 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
89 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 102 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
90) 103)
91${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 104${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
92 105
93postels_law=true 106postels_law=true
94AC_ARG_ENABLE([postels-law], 107AC_ARG_ENABLE([postels-law],
95 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 108 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
96 [ test "${enableval}" = "no" && postels_law=false ] 109 [ test "${enableval}" = "no" && postels_law=false ]
97) 110)
98$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 111$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
99 112
100AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 113AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])