summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53e22ba..4f9b6c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,62 +1,62 @@
1AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9AC_PROG_LIBTOOL 9AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG
10 11
11AC_HEADER_STDC 12AC_HEADER_STDC
12 13
13AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 14AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
14AC_WITH_PKGCONFIG
15 15
16PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 16PKG_CHECK_MODULES([OPENSSL],[openssl],,[
17 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 17 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
18]) 18])
19 19
20WANT_KONFORKA="yes" 20WANT_KONFORKA="yes"
21AC_ARG_ENABLE([konforka], 21AC_ARG_ENABLE([konforka],
22 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 22 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
23 [ 23 [
24 test "${enableval}" = "no" && WANT_KONFORKA="no" 24 test "${enableval}" = "no" && WANT_KONFORKA="no"
25 ] 25 ]
26) 26)
27if test "${WANT_KONFORKA}" = "yes" ; then 27if test "${WANT_KONFORKA}" = "yes" ; then
28 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 28 PKG_CHECK_MODULES([KONFORKA],[konforka],[
29 AC_SUBST([KONFORKA_CFLAGS]) 29 AC_SUBST([KONFORKA_CFLAGS])
30 AC_SUBST([KONFORKA_LIBS]) 30 AC_SUBST([KONFORKA_LIBS])
31 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 31 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
32 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 32 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
33 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 33 AC_SUBST([KONFORKA_KONFORKA],[konforka])
34 ],[true]) 34 ],[true])
35fi 35fi
36 36
37WANT_DOXYGEN="yes" 37WANT_DOXYGEN="yes"
38AC_ARG_ENABLE([doxygen], 38AC_ARG_ENABLE([doxygen],
39 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 39 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
40 [ 40 [
41 test "${enableval}" = "no" && WANT_DOXYGEN="no" 41 test "${enableval}" = "no" && WANT_DOXYGEN="no"
42 ] 42 ]
43) 43)
44if test "${WANT_DOXYGEN}" = "yes" ; then 44if test "${WANT_DOXYGEN}" = "yes" ; then
45 AC_WITH_DOXYGEN 45 AC_WITH_DOXYGEN
46 AC_WITH_DOT 46 AC_WITH_DOT
47else 47else
48 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 48 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
49 AM_CONDITIONAL([HAVE_DOT],[false]) 49 AM_CONDITIONAL([HAVE_DOT],[false])
50fi 50fi
51 51
52LIBCURL_CHECK_CONFIG(,,,[ 52LIBCURL_CHECK_CONFIG(,,,[
53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
54]) 54])
55 55
56PKG_CHECK_MODULES([PCRE],[libpcre],,[ 56PKG_CHECK_MODULES([PCRE],[libpcre],,[
57 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 57 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
58]) 58])
59 59
60curl_ssl_verify_host="true" 60curl_ssl_verify_host="true"
61AC_ARG_ENABLE([ssl-verify-host], 61AC_ARG_ENABLE([ssl-verify-host],
62 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 62 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),