summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e636253..606e644 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,63 +1,64 @@
1AC_INIT([libopkele], [2.0.4], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.4], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d]) 4AC_CONFIG_MACRO_DIR([aclocal.d])
5AC_CONFIG_AUX_DIR([aux.d]) 5AC_CONFIG_AUX_DIR([aux.d])
6AM_INIT_AUTOMAKE([dist-bzip2]) 6AM_INIT_AUTOMAKE([dist-bzip2])
7 7
8AC_PROG_INSTALL 8AC_PROG_INSTALL
9AC_PROG_CXX 9AC_PROG_CXX
10AC_PROG_CC 10AC_PROG_CC
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12PKG_PROG_PKG_CONFIG 12PKG_PROG_PKG_CONFIG
13 13
14AC_HEADER_STDC 14AC_HEADER_STDC
15AC_CHECK_FUNCS([timegm]) 15AC_CHECK_FUNCS([timegm])
16AC_CHECK_HEADERS([ext/algorithm.h])
16 17
17AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 18AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
18 19
19AC_MSG_CHECKING([for source tree version]) 20AC_MSG_CHECKING([for source tree version])
20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 21if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 22 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 23 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 24 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 25 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
25else 26else
26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 27 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
27fi 28fi
28AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 29AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
29AC_SUBST([PACKAGE_SRC_VERSION]) 30AC_SUBST([PACKAGE_SRC_VERSION])
30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 31AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
31 32
32tr1_mem_std="false" 33tr1_mem_std="false"
33tr1_mem_boost="false" 34tr1_mem_boost="false"
34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 35AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 36AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
36tr1_mem="" 37tr1_mem=""
37AC_ARG_WITH([tr1-memory], 38AC_ARG_WITH([tr1-memory],
38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 39 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
39 [ tr1_mem="$withval" ] 40 [ tr1_mem="$withval" ]
40) 41)
41AC_MSG_CHECKING([for tr1/memory implementation to use]) 42AC_MSG_CHECKING([for tr1/memory implementation to use])
42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 43test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 44test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
44if test -z "$tr1_mem" ; then 45if test -z "$tr1_mem" ; then
45 AC_MSG_RESULT([none found]) 46 AC_MSG_RESULT([none found])
46else 47else
47 AC_MSG_RESULT([$tr1_mem]) 48 AC_MSG_RESULT([$tr1_mem])
48fi 49fi
49case "$tr1_mem" in 50case "$tr1_mem" in
50 std) 51 std)
51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 52 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
52 OPKELE_TR1_MEM_NS=std::tr1 53 OPKELE_TR1_MEM_NS=std::tr1
53 OPKELE_TR1_MEM_HEADER=tr1/memory 54 OPKELE_TR1_MEM_HEADER=tr1/memory
54 ;; 55 ;;
55 boost) 56 boost)
56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 57 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
57 OPKELE_TR1_MEM_NS=boost 58 OPKELE_TR1_MEM_NS=boost
58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 59 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
59 ;; 60 ;;
60 *) 61 *)
61 AC_MSG_ERROR([no shared_ptr<> implementation found]) 62 AC_MSG_ERROR([no shared_ptr<> implementation found])
62 ;; 63 ;;
63esac 64esac