summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5fb6bec..7fa2f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,22 +163,12 @@ AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
163 ]) 163 ])
164],[ 164],[
165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \ 165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
167]) 167])
168 168
169if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
170 AC_SUBST([PCRE_CFLAGS])
171 AC_SUBST([PCRE_LIBS])
172 :
173else
174 PKG_CHECK_MODULES([PCRE],[libpcre],,[
175 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
176 ])
177fi
178
179PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
180AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
181PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
182AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
183PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
184AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 174AM_CONDITIONAL([HAVE_UUID],[$have_uuid])