-rw-r--r-- | configure.ac | 47 |
1 files changed, 3 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac index 00c6bc4..53e22ba 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -48,60 +48,19 @@ else | |||
48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
49 | AM_CONDITIONAL([HAVE_DOT],[false]) | 49 | AM_CONDITIONAL([HAVE_DOT],[false]) |
50 | fi | 50 | fi |
51 | 51 | ||
52 | LIBCURL_CHECK_CONFIG(,,,[ | 52 | LIBCURL_CHECK_CONFIG(,,,[ |
53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
54 | ]) | 54 | ]) |
55 | 55 | ||
56 | want_pcre_impl="" | 56 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
57 | AC_ARG_WITH([pcre-bindings], | 57 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
58 | AC_HELP_STRING([--with-pcre-bindings=(pcrepp|none|libpcrecpp)],[Specify which pcre c++ bindings to use. 'pcrepp' stands for quite sensible library, found at http://www.daemon.de/PCRE/, 'libcrecpp' makes use of crappy bindings by google and 'none' disables internal implementation of OP discovery]), | 58 | ]) |
59 | [ | ||
60 | case "$withval" in | ||
61 | pcrepp) want_pcre_impl="pcrepp" ;; | ||
62 | libpcrecpp) want_pcre_impl="libpcrecpp" ;; | ||
63 | none) want_pcre_impl="none";; | ||
64 | *) AC_MSG_ERROR([I'm not sure I understand what do you want for a pcre c++ bindings]) ;; | ||
65 | esac | ||
66 | ] | ||
67 | ) | ||
68 | |||
69 | found_pcre_impl="" | ||
70 | |||
71 | if test -z "$want_pcre_impl" -o "$want_pcre_impl" = "pcrepp" ; then | ||
72 | AC_WITH_PCRE([ | ||
73 | AC_WITH_PCREPP([ | ||
74 | found_pcre_impl=pcrepp | ||
75 | ]) | ||
76 | ],[ | ||
77 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) | ||
78 | ] | ||
79 | ) | ||
80 | test "$want_pcre_impl,$found_pcre_impl" = "pcrepp," && AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) | ||
81 | fi | ||
82 | |||
83 | if test "$found_pcre_impl,$want_pcre_impl" = "," -o "$want_pcre_impl" = "libpcrecpp" ; then | ||
84 | test -z "$want_pcre_impl" || AC_MSG_NOTICE([You want to use crappy libpcre c++ bindings]) | ||
85 | PKG_CHECK_MODULES([LIBPCRECPP],[libpcrecpp],[ | ||
86 | found_pcre_impl=libpcrecpp | ||
87 | CXXFLAGS="$CXXFLAGS $LIBPCRECPP_CFLAGS" | ||
88 | LIBS="$LIBS $LIBPCRECPP_LIBS" | ||
89 | ],[ | ||
90 | test -z "$want_pcre_impl" || AC_MSG_ERROR([no libpcre c++ bindings found. why would you want it if you don't have it installed?]) | ||
91 | ] | ||
92 | ) | ||
93 | fi | ||
94 | test "$want_pcre_impl,$found_pcre_impl" = "," && AC_MSG_ERROR([no pcre c++ bindings found, use --with-pcre-bindings=none to disable code that makes use of it]) | ||
95 | |||
96 | case "$found_pcre_impl" in | ||
97 | pcrepp) AC_DEFINE([USE_PCREPP],,[defined if pcre++ is to be used]) ;; | ||
98 | libpcrecpp) AC_DEFINE([USE_LIBPCRECPP],,[defined if crappy google bindings are to be used]) ;; | ||
99 | esac | ||
100 | 59 | ||
101 | curl_ssl_verify_host="true" | 60 | curl_ssl_verify_host="true" |
102 | AC_ARG_ENABLE([ssl-verify-host], | 61 | AC_ARG_ENABLE([ssl-verify-host], |
103 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 62 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
104 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 63 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
105 | ) | 64 | ) |
106 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 65 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
107 | 66 | ||