summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9fc5c9d..5fb6bec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,97 +1,97 @@
1AC_INIT([libopkele], [2.0.2], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.3], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d]) 4AC_CONFIG_MACRO_DIR([aclocal.d])
5AC_CONFIG_AUX_DIR([aux.d]) 5AC_CONFIG_AUX_DIR([aux.d])
6AM_INIT_AUTOMAKE([dist-bzip2]) 6AM_INIT_AUTOMAKE([dist-bzip2])
7 7
8AC_PROG_INSTALL 8AC_PROG_INSTALL
9AC_PROG_CXX 9AC_PROG_CXX
10AC_PROG_CC 10AC_PROG_CC
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12PKG_PROG_PKG_CONFIG 12PKG_PROG_PKG_CONFIG
13 13
14AC_HEADER_STDC 14AC_HEADER_STDC
15AC_CHECK_FUNCS([timegm]) 15AC_CHECK_FUNCS([timegm])
16 16
17AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 17AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
18 18
19AC_MSG_CHECKING([for source tree version]) 19AC_MSG_CHECKING([for source tree version])
20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
25else 25else
26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
27fi 27fi
28AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 28AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
29AC_SUBST([PACKAGE_SRC_VERSION]) 29AC_SUBST([PACKAGE_SRC_VERSION])
30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
31 31
32tr1_mem_std="false" 32tr1_mem_std="false"
33tr1_mem_boost="false" 33tr1_mem_boost="false"
34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
36tr1_mem="" 36tr1_mem=""
37AC_ARG_WITH([tr1-memory], 37AC_ARG_WITH([tr1-memory],
38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
39 [ tr1_mem="$withval" ] 39 [ tr1_mem="$withval" ]
40) 40)
41AC_MSG_CHECKING([for tr1/memory implementation to use]) 41AC_MSG_CHECKING([for tr1/memory implementation to use])
42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
44if test -z "$tr1_mem" ; then 44if test -z "$tr1_mem" ; then
45 AC_MSG_RESULT([none found]) 45 AC_MSG_RESULT([none found])
46else 46else
47 AC_MSG_RESULT([$tr1_mem]) 47 AC_MSG_RESULT([$tr1_mem])
48fi 48fi
49case "$tr1_mem" in 49case "$tr1_mem" in
50 std) 50 std)
51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
52 OPKELE_TR1_MEM_NS=std::tr1 52 OPKELE_TR1_MEM_NS=std::tr1
53 OPKELE_TR1_MEM_HEADER=tr1/memory 53 OPKELE_TR1_MEM_HEADER=tr1/memory
54 ;; 54 ;;
55 boost) 55 boost)
56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
57 OPKELE_TR1_MEM_NS=boost 57 OPKELE_TR1_MEM_NS=boost
58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
59 ;; 59 ;;
60 *) 60 *)
61 AC_MSG_ERROR([no shared_ptr<> implementation found]) 61 AC_MSG_ERROR([no shared_ptr<> implementation found])
62 ;; 62 ;;
63esac 63esac
64AC_SUBST([OPKELE_TR1_MEM_NS]) 64AC_SUBST([OPKELE_TR1_MEM_NS])
65AC_SUBST([OPKELE_TR1_MEM_HEADER]) 65AC_SUBST([OPKELE_TR1_MEM_HEADER])
66 66
67AC_MSG_CHECKING([for deprecated attribute support]) 67AC_MSG_CHECKING([for deprecated attribute support])
68AC_COMPILE_IFELSE([ 68AC_COMPILE_IFELSE([
69 int __attribute__((deprecated)) deprecated_function(); 69 int __attribute__((deprecated)) deprecated_function();
70 ],[ 70 ],[
71 AC_MSG_RESULT([yes]) 71 AC_MSG_RESULT([yes])
72 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 72 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
73 ],[ 73 ],[
74 AC_MSG_RESULT([no]) 74 AC_MSG_RESULT([no])
75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
76 ] 76 ]
77) 77)
78 78
79AC_LANG_PUSH([C++]) 79AC_LANG_PUSH([C++])
80AC_MSG_CHECKING([for abi::__cxa_demangle]) 80AC_MSG_CHECKING([for abi::__cxa_demangle])
81AC_COMPILE_IFELSE([ 81AC_COMPILE_IFELSE([
82 #include <typeinfo> 82 #include <typeinfo>
83 using namespace std; 83 using namespace std;
84 #include <cxxabi.h> 84 #include <cxxabi.h>
85 int main(int c,char **v) { 85 int main(int c,char **v) {
86 int dstat; 86 int dstat;
87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
88 return 0; 88 return 0;
89 } 89 }
90 ],[ 90 ],[
91 AC_MSG_RESULT([yes]) 91 AC_MSG_RESULT([yes])
92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
93 ],[ 93 ],[
94 AC_MSG_RESULT([no]) 94 AC_MSG_RESULT([no])
95 ] 95 ]
96) 96)
97AC_LANG_POP([C++]) 97AC_LANG_POP([C++])