-rw-r--r-- | configure.ac | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index a49177f..0aa1272 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -85,169 +85,173 @@ AC_COMPILE_IFELSE([ | |||
85 | return 0; | 85 | return 0; |
86 | } | 86 | } |
87 | ],[ | 87 | ],[ |
88 | AC_MSG_RESULT([yes]) | 88 | AC_MSG_RESULT([yes]) |
89 | AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) | 89 | AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) |
90 | ],[ | 90 | ],[ |
91 | AC_MSG_RESULT([no]) | 91 | AC_MSG_RESULT([no]) |
92 | ] | 92 | ] |
93 | ) | 93 | ) |
94 | AC_LANG_POP([C++]) | 94 | AC_LANG_POP([C++]) |
95 | 95 | ||
96 | 96 | ||
97 | 97 | ||
98 | 98 | ||
99 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 99 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
100 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 100 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
101 | ]) | 101 | ]) |
102 | 102 | ||
103 | WANT_KONFORKA="yes" | 103 | WANT_KONFORKA="yes" |
104 | AC_ARG_ENABLE([konforka], | 104 | AC_ARG_ENABLE([konforka], |
105 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 105 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
106 | [ | 106 | [ |
107 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 107 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
108 | ] | 108 | ] |
109 | ) | 109 | ) |
110 | if test "${WANT_KONFORKA}" = "yes" ; then | 110 | if test "${WANT_KONFORKA}" = "yes" ; then |
111 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 111 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
112 | AC_SUBST([KONFORKA_CFLAGS]) | 112 | AC_SUBST([KONFORKA_CFLAGS]) |
113 | AC_SUBST([KONFORKA_LIBS]) | 113 | AC_SUBST([KONFORKA_LIBS]) |
114 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 114 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
115 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 115 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
116 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 116 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
117 | ],[true]) | 117 | ],[true]) |
118 | fi | 118 | fi |
119 | 119 | ||
120 | WANT_DOXYGEN="yes" | 120 | WANT_DOXYGEN="yes" |
121 | AC_ARG_ENABLE([doxygen], | 121 | AC_ARG_ENABLE([doxygen], |
122 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 122 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
123 | [ | 123 | [ |
124 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 124 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
125 | ] | 125 | ] |
126 | ) | 126 | ) |
127 | if test "${WANT_DOXYGEN}" = "yes" ; then | 127 | if test "${WANT_DOXYGEN}" = "yes" ; then |
128 | AC_WITH_DOXYGEN | 128 | AC_WITH_DOXYGEN |
129 | AC_WITH_DOT | 129 | AC_WITH_DOT |
130 | else | 130 | else |
131 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 131 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
132 | AM_CONDITIONAL([HAVE_DOT],[false]) | 132 | AM_CONDITIONAL([HAVE_DOT],[false]) |
133 | fi | 133 | fi |
134 | 134 | ||
135 | LIBCURL_CHECK_CONFIG(,,,[ | 135 | LIBCURL_CHECK_CONFIG(,,,[ |
136 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 136 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
137 | ]) | 137 | ]) |
138 | 138 | ||
139 | AC_CHECK_HEADER([expat.h],[ | 139 | AC_CHECK_HEADER([expat.h],[ |
140 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ | 140 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ |
141 | EXPAT_LIBS=-lexpat | 141 | EXPAT_LIBS=-lexpat |
142 | EXPAT_CFLAGS= | 142 | EXPAT_CFLAGS= |
143 | AC_SUBST([EXPAT_LIBS]) | 143 | AC_SUBST([EXPAT_LIBS]) |
144 | AC_SUBST([EXPAT_CFLAGS]) | 144 | AC_SUBST([EXPAT_CFLAGS]) |
145 | ],[ | 145 | ],[ |
146 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 146 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
147 | ]) | 147 | ]) |
148 | ],[ | 148 | ],[ |
149 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 149 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
150 | ]) | 150 | ]) |
151 | 151 | ||
152 | AC_CHECK_HEADER([tidy.h],[ | 152 | AC_CHECK_HEADER([tidy.h],[ |
153 | AC_CHECK_LIB([tidy],[tidyParseBuffer],[ | 153 | AC_CHECK_LIB([tidy],[tidyParseBuffer],[ |
154 | TIDY_LIBS=-ltidy | 154 | TIDY_LIBS=-ltidy |
155 | TIDY_CFLAGS= | 155 | TIDY_CFLAGS= |
156 | AC_SUBST([TIDY_LIBS]) | 156 | AC_SUBST([TIDY_LIBS]) |
157 | AC_SUBST([TIDY_CFLAGS]) | 157 | AC_SUBST([TIDY_CFLAGS]) |
158 | ],[ | 158 | ],[ |
159 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) | 159 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) |
160 | ]) | 160 | ]) |
161 | ],[ | 161 | ],[ |
162 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) | 162 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) |
163 | ]) | 163 | ]) |
164 | 164 | ||
165 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 165 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
166 | AC_SUBST([PCRE_CFLAGS]) | 166 | AC_SUBST([PCRE_CFLAGS]) |
167 | AC_SUBST([PCRE_LIBS]) | 167 | AC_SUBST([PCRE_LIBS]) |
168 | : | 168 | : |
169 | else | 169 | else |
170 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 170 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
171 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 171 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
172 | ]) | 172 | ]) |
173 | fi | 173 | fi |
174 | 174 | ||
175 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) | 175 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) |
176 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) | 176 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) |
177 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) | 177 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) |
178 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) | 178 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) |
179 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) | 179 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) |
180 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) | 180 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) |
181 | if $have_uuid ; then | ||
182 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) | ||
183 | AC_SUBST([UUID_UUID],[uuid]) | ||
184 | fi | ||
181 | 185 | ||
182 | curl_ssl_verify_host="true" | 186 | curl_ssl_verify_host="true" |
183 | AC_ARG_ENABLE([ssl-verify-host], | 187 | AC_ARG_ENABLE([ssl-verify-host], |
184 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 188 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
185 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 189 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
186 | ) | 190 | ) |
187 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 191 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
188 | 192 | ||
189 | curl_ssl_verify_peer="true" | 193 | curl_ssl_verify_peer="true" |
190 | AC_ARG_ENABLE([ssl-verify-peer], | 194 | AC_ARG_ENABLE([ssl-verify-peer], |
191 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 195 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
192 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 196 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
193 | ) | 197 | ) |
194 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 198 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
195 | 199 | ||
196 | postels_law=true | 200 | postels_law=true |
197 | AC_ARG_ENABLE([postels-law], | 201 | AC_ARG_ENABLE([postels-law], |
198 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 202 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
199 | [ test "${enableval}" = "no" && postels_law=false ] | 203 | [ test "${enableval}" = "no" && postels_law=false ] |
200 | ) | 204 | ) |
201 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 205 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
202 | 206 | ||
203 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | 207 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) |
204 | 208 | ||
205 | nitpick=false | 209 | nitpick=false |
206 | AC_ARG_ENABLE([nitpicking], | 210 | AC_ARG_ENABLE([nitpicking], |
207 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | 211 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), |
208 | [ test "$enableval" = "no" || nitpick=true ] | 212 | [ test "$enableval" = "no" || nitpick=true ] |
209 | ) | 213 | ) |
210 | if $nitpick ; then | 214 | if $nitpick ; then |
211 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | 215 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ |
212 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | 216 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ |
213 | -Wredundant-decls -ansi" | 217 | -Wredundant-decls -ansi" |
214 | # -Wlogical-op -Wmissing-noreturn | 218 | # -Wlogical-op -Wmissing-noreturn |
215 | C_NITPICK="$CPP_NITPICK" | 219 | C_NITPICK="$CPP_NITPICK" |
216 | CXX_NITPICK="$C_NITPICK" | 220 | CXX_NITPICK="$C_NITPICK" |
217 | 221 | ||
218 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" | 222 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" |
219 | CFLAGS="$CFLAGS $C_NITPICK" | 223 | CFLAGS="$CFLAGS $C_NITPICK" |
220 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" | 224 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" |
221 | fi | 225 | fi |
222 | 226 | ||
223 | ndebug=true | 227 | ndebug=true |
224 | AC_ARG_ENABLE([debug], | 228 | AC_ARG_ENABLE([debug], |
225 | AC_HELP_STRING([--enable-debug],[enable debugging code]), | 229 | AC_HELP_STRING([--enable-debug],[enable debugging code]), |
226 | [ test "$enableval" = "no" || ndebug=false ] | 230 | [ test "$enableval" = "no" || ndebug=false ] |
227 | ) | 231 | ) |
228 | if $ndebug ; then | 232 | if $ndebug ; then |
229 | CPPFLAGS_DEBUG="-DNDEBUG" | 233 | CPPFLAGS_DEBUG="-DNDEBUG" |
230 | else | 234 | else |
231 | CPPFLAGS_DEBUG="" | 235 | CPPFLAGS_DEBUG="" |
232 | fi | 236 | fi |
233 | AC_SUBST([CPPFLAGS_DEBUG]) | 237 | AC_SUBST([CPPFLAGS_DEBUG]) |
234 | 238 | ||
235 | xri_proxy_url="https://xri.net/" | 239 | xri_proxy_url="https://xri.net/" |
236 | AC_MSG_CHECKING([for XRI resolver proxy]) | 240 | AC_MSG_CHECKING([for XRI resolver proxy]) |
237 | AC_ARG_ENABLE([xri-proxy], | 241 | AC_ARG_ENABLE([xri-proxy], |
238 | AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]), | 242 | AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]), |
239 | [ xri_proxy_url="$withval" ] | 243 | [ xri_proxy_url="$withval" ] |
240 | ) | 244 | ) |
241 | AC_MSG_RESULT([$xri_proxy_url]) | 245 | AC_MSG_RESULT([$xri_proxy_url]) |
242 | AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) | 246 | AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) |
243 | 247 | ||
244 | AC_CONFIG_FILES([ | 248 | AC_CONFIG_FILES([ |
245 | Makefile | 249 | Makefile |
246 | libopkele.pc | 250 | libopkele.pc |
247 | Doxyfile | 251 | Doxyfile |
248 | include/Makefile | 252 | include/Makefile |
249 | include/opkele/tr1-mem.h | 253 | include/opkele/tr1-mem.h |
250 | lib/Makefile | 254 | lib/Makefile |
251 | test/Makefile | 255 | test/Makefile |
252 | ]) | 256 | ]) |
253 | AC_OUTPUT | 257 | AC_OUTPUT |