summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48a5efb..2b94b41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,19 @@ LIBCURL_CHECK_CONFIG(,,,[
66 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 66 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
67]) 67])
68 68
69AC_CHECK_HEADER([expat.h],[
70 AC_CHECK_LIB([expat],[XML_ParserCreate],[
71 EXPAT_LIBS=-lexpat
72 EXPAT_CFLAGS=
73 AC_SUBST([EXPAT_LIBS])
74 AC_SUBST([EXPAT_CFLAGS])
75 ],[
76 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
77 ])
78],[
79 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
80])
81
69if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 82if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
70 AC_SUBST([PCRE_CFLAGS]) 83 AC_SUBST([PCRE_CFLAGS])
71 AC_SUBST([PCRE_LIBS]) 84 AC_SUBST([PCRE_LIBS])