summaryrefslogtreecommitdiffabout
path: root/test/Makefile.am
Unidiff
Diffstat (limited to 'test/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--test/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 61e3787..8fedf48 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
1noinst_PROGRAMS = test idiscover RP.cgi 1noinst_PROGRAMS = test idiscover RP.cgi OP.cgi
2 2
3AM_CPPFLAGS=${CPPFLAGS_DEBUG} 3AM_CPPFLAGS=${CPPFLAGS_DEBUG}
4DEFAULT_INCLUDES = -I${top_builddir} 4DEFAULT_INCLUDES = -I${top_builddir}
@@ -8,8 +8,8 @@ test_SOURCES = test.cc
8test_LDADD = ${top_builddir}/lib/libopkele.la 8test_LDADD = ${top_builddir}/lib/libopkele.la
9 9
10EXTRA_DIST= \ 10EXTRA_DIST= \
11 sqlite.h \ 11 sqlite.h kingate_openid_message.h \
12 RP-db.sql 12 RP-db.sql OP-db.sql
13 13
14idiscover_SOURCES = idiscover.cc 14idiscover_SOURCES = idiscover.cc
15idiscover_LDADD = ${top_builddir}/lib/libopkele.la 15idiscover_LDADD = ${top_builddir}/lib/libopkele.la
@@ -31,8 +31,20 @@ RP-db.cc: RP-db.sql
31 echo ';' \ 31 echo ';' \
32 ) >$@ 32 ) >$@
33 33
34OP_cgi_SOURCES = OP.cc
35nodist_OP_cgi_SOURCES = OP-db.cc
36OP_cgi_LDADD = ${RP_cgi_LDADD}
37OP_cgi_CFLAGS = ${RP_cgi_CFLAGS}
38
39OP-db.cc: OP-db.sql
40 ( \
41 echo 'const char * __OP_db_bootstrap = ' && \
42 sed -e 's/^/"/' -e 's/$$/"/' $< && \
43 echo ';' \
44 ) >$@
45
34clean-local: 46clean-local:
35 rm -f RP-db.cc 47 rm -f RP-db.cc OP-db.cc
36 48
37endif #HAVE_UUID 49endif #HAVE_UUID
38endif #HAVE_KINGATE 50endif #HAVE_KINGATE