author | Michael Krelin <hacker@klever.net> | 2008-04-05 11:17:33 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2008-04-05 11:17:33 (UTC) |
commit | 04fb190243442e83349f129b523ab747e58100bf (patch) (unidiff) | |
tree | ddc28357fbe78b07fd3a5e0aa8088130bf305829 /configure.ac | |
download | napkin-04fb190243442e83349f129b523ab747e58100bf.zip napkin-04fb190243442e83349f129b523ab747e58100bf.tar.gz napkin-04fb190243442e83349f129b523ab747e58100bf.tar.bz2 |
Initial commit into public repository0.0
Signed-off-by: Michael Krelin <hacker@klever.net>
-rw-r--r-- | configure.ac | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac new file mode 100644 index 0000000..3ca0b4e --- a/dev/null +++ b/configure.ac | |||
@@ -0,0 +1,66 @@ | |||
1 | AC_INIT([napkin], [0.0], [napkin-bugs@klever.net]) | ||
2 | AC_CONFIG_AUX_DIR([aux.d]) | ||
3 | AC_CONFIG_SRCDIR([src/napkin.cc]) | ||
4 | AC_CONFIG_HEADERS([config.h]) | ||
5 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
6 | |||
7 | AC_PROG_INSTALL | ||
8 | AC_PROG_CXX | ||
9 | AC_PROG_CC | ||
10 | AC_PROG_LIBTOOL | ||
11 | PKG_PROG_PKG_CONFIG | ||
12 | |||
13 | AC_HEADER_STDC | ||
14 | |||
15 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | ||
16 | |||
17 | PKG_CHECK_MODULES([MODULES],[gtkmm-2.4 sqlite3],,[ | ||
18 | AC_MSG_ERROR([not all dependencies could be satisfied]) | ||
19 | ]) | ||
20 | |||
21 | AC_MSG_CHECKING([whether to enable debugging code]) | ||
22 | ndebug=true | ||
23 | AC_ARG_ENABLE([debug], | ||
24 | AC_HELP_STRING([--enable-debug],[enable debugging/development code]), | ||
25 | [ test "$enableval" = "no" || ndebug=false ] | ||
26 | ) | ||
27 | if $ndebug ; then | ||
28 | AC_MSG_RESULT([no]) | ||
29 | CPPFLAGS="${CPPFLAGS}-DNDEBUG" | ||
30 | else | ||
31 | AC_MSG_RESULT([yes]) | ||
32 | fi | ||
33 | |||
34 | nitpick=false | ||
35 | AC_MSG_CHECKING([whether to enable compiler nitpicking]) | ||
36 | AC_ARG_ENABLE([nitpicking], | ||
37 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | ||
38 | [ test "$enableval" = "no" || nitpick=true ] | ||
39 | ) | ||
40 | if $nitpick ; then | ||
41 | AC_MSG_RESULT([yes]) | ||
42 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | ||
43 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | ||
44 | -Wredundant-decls -ansi" | ||
45 | # -Wlogical-op -Wmissing-noreturn | ||
46 | C_NITPICK="$CPP_NITPICK" | ||
47 | CXX_NITPICK="$C_NITPICK" | ||
48 | |||
49 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" | ||
50 | CFLAGS="$CFLAGS $C_NITPICK" | ||
51 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" | ||
52 | else | ||
53 | AC_MSG_RESULT([no]) | ||
54 | fi | ||
55 | |||
56 | |||
57 | AC_CONFIG_FILES([ | ||
58 | Makefile | ||
59 | include/Makefile | ||
60 | lib/Makefile | ||
61 | src/Makefile | ||
62 | test/Makefile | ||
63 | ]) | ||
64 | AC_OUTPUT | ||
65 | |||
66 | dnl vim:set ft=m4 sw=1: | ||