summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac66
1 files changed, 66 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3ca0b4e
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,66 @@
1AC_INIT([napkin], [0.0], [napkin-bugs@klever.net])
2AC_CONFIG_AUX_DIR([aux.d])
3AC_CONFIG_SRCDIR([src/napkin.cc])
4AC_CONFIG_HEADERS([config.h])
5AM_INIT_AUTOMAKE([dist-bzip2])
6
7AC_PROG_INSTALL
8AC_PROG_CXX
9AC_PROG_CC
10AC_PROG_LIBTOOL
11PKG_PROG_PKG_CONFIG
12
13AC_HEADER_STDC
14
15AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
16
17PKG_CHECK_MODULES([MODULES],[gtkmm-2.4 sqlite3],,[
18 AC_MSG_ERROR([not all dependencies could be satisfied])
19])
20
21AC_MSG_CHECKING([whether to enable debugging code])
22ndebug=true
23AC_ARG_ENABLE([debug],
24 AC_HELP_STRING([--enable-debug],[enable debugging/development code]),
25 [ test "$enableval" = "no" || ndebug=false ]
26)
27if $ndebug ; then
28 AC_MSG_RESULT([no])
29 CPPFLAGS="${CPPFLAGS}-DNDEBUG"
30else
31 AC_MSG_RESULT([yes])
32fi
33
34nitpick=false
35AC_MSG_CHECKING([whether to enable compiler nitpicking])
36AC_ARG_ENABLE([nitpicking],
37 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
38 [ test "$enableval" = "no" || nitpick=true ]
39)
40if $nitpick ; then
41 AC_MSG_RESULT([yes])
42 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
43 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
44 -Wredundant-decls -ansi"
45 # -Wlogical-op -Wmissing-noreturn
46 C_NITPICK="$CPP_NITPICK"
47 CXX_NITPICK="$C_NITPICK"
48
49 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
50 CFLAGS="$CFLAGS $C_NITPICK"
51 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
52else
53 AC_MSG_RESULT([no])
54fi
55
56
57AC_CONFIG_FILES([
58 Makefile
59 include/Makefile
60 lib/Makefile
61 src/Makefile
62 test/Makefile
63])
64AC_OUTPUT
65
66dnl vim:set ft=m4 sw=1: