summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ca0b4e..fbf373b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,24 +1,28 @@
AC_INIT([napkin], [0.0], [napkin-bugs@klever.net])
AC_CONFIG_AUX_DIR([aux.d])
AC_CONFIG_SRCDIR([src/napkin.cc])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
AC_PROG_INSTALL
AC_PROG_CXX
AC_PROG_CC
AC_PROG_LIBTOOL
PKG_PROG_PKG_CONFIG
+onegetcwd=false
+AC_CHECK_FUNCS([get_current_dir_name getcwd],[onegetcwd=true;break])
+$onegetcwd || AC_MSG_ERROR([no function to get current directory found. weird.])
+
AC_HEADER_STDC
AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
PKG_CHECK_MODULES([MODULES],[gtkmm-2.4 sqlite3],,[
AC_MSG_ERROR([not all dependencies could be satisfied])
])
AC_MSG_CHECKING([whether to enable debugging code])
ndebug=true
AC_ARG_ENABLE([debug],
AC_HELP_STRING([--enable-debug],[enable debugging/development code]),