summaryrefslogtreecommitdiffabout
path: root/lib/Makefile.am
Side-by-side diff
Diffstat (limited to 'lib/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--lib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..bf55849
--- a/dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,11 @@
+lib_LTLIBRARIES = libnapkin.la
+
+INCLUDES = -I${top_builddir}/include/ -I${top_srcdir}/include/ \
+ ${MODULES_CFLAGS}
+LIBS = ${MODULES_CFLAGS}
+
+libnapkin_la_SOURCES = \
+ st-decode.cc st-download.cc \
+ hypnodata.cc \
+ util.cc
+libnapkin_la_LDFLAGS = -version-info 0:0:0