author | Michael Krelin <hacker@klever.net> | 2005-01-30 00:57:53 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2005-01-30 00:57:53 (UTC) |
commit | 71f4cc84c3788c6904ede17cd626a9ca9c349e3b (patch) (unidiff) | |
tree | cfe7736ae3416ad314b7451b756e587335c357c7 /Makefile.am | |
parent | acd2a536dd6bb3ef9438482725f77ac9044ae79b (diff) | |
download | sitecing-71f4cc84c3788c6904ede17cd626a9ca9c349e3b.zip sitecing-71f4cc84c3788c6904ede17cd626a9ca9c349e3b.tar.gz sitecing-71f4cc84c3788c6904ede17cd626a9ca9c349e3b.tar.bz2 |
initial commit into repository
-rw-r--r-- | Makefile.am | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am new file mode 100644 index 0000000..cf1fe6d --- a/dev/null +++ b/Makefile.am | |||
@@ -0,0 +1,35 @@ | |||
1 | EXTRA_DIST = \ | ||
2 | $(addprefix htdocs/,.htaccess index.chtml sources.chtml style.css view.chtml) \ | ||
3 | $(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \ | ||
4 | $(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \ | ||
5 | $(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \ | ||
6 | $(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \ | ||
7 | $(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \ | ||
8 | autogen.sh \ | ||
9 | NEWS NEWS.xml NEWS.xsl | ||
10 | |||
11 | DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck | ||
12 | |||
13 | all-local: NEWS sitecode restart restart-apache | ||
14 | distclean-local: | ||
15 | rm -rf config.sitecing \ | ||
16 | logs fastcgi-bin run cache | ||
17 | |||
18 | NEWS: NEWS.xsl NEWS.xml | ||
19 | ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml | ||
20 | |||
21 | sitecode: conf/sitecing.conf include/acconfig.h | ||
22 | ${SHELL} bin/build | ||
23 | restart: conf/sitecing.conf conf/dudki.conf | ||
24 | if !DISTCHECKING | ||
25 | if HAVE_DUDKI | ||
26 | sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r" | ||
27 | else | ||
28 | kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run | ||
29 | endif | ||
30 | endif !DISTCHECKING | ||
31 | |||
32 | restart-apache: conf/httpd.conf | ||
33 | if !DISTCHECKING | ||
34 | @APACHE_RESTART_CMD@ | ||
35 | endif !DISTCHECKING | ||