summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-02-13 17:01:51 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-13 17:01:51 (UTC)
commit9aa669090e978dce5e1f4d1ca9d23a4d92208518 (patch) (side-by-side diff)
tree37b8b1a8df046d2154af30f85f251ca5271672e5 /configure.ac
parentce1f37aae46ea95020d7b865f7a80e8abdfad0d8 (diff)
downloadsitecing-9aa669090e978dce5e1f4d1ca9d23a4d92208518.zip
sitecing-9aa669090e978dce5e1f4d1ca9d23a4d92208518.tar.gz
sitecing-9aa669090e978dce5e1f4d1ca9d23a4d92208518.tar.bz2
1. made fastcgi support optional
2. added 'plain' cgi support (kingate 0.0.1 required for it) 3. bumped version to 0.0.1 4. excluded doxygen 'dox' target from 'all'
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index acd34b9..0da7658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,37 +1,55 @@
-AC_INIT([sitecing], [0.0], [sitecing-bugs@klever.net])
+AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net])
AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
AC_PROG_INSTALL
AC_PROG_AWK
AC_PROG_CXX
AC_PROG_CC
AM_PROG_LEX
AC_PROG_LIBTOOL
AC_HEADER_STDC
AC_CHECK_HEADERS([stdlib.h unistd.h])
AC_C_CONST
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_WITH_PKGCONFIG
-PKG_CHECK_MODULES([KINGATE],[kingate-fcgi],,[
+PKG_CHECK_MODULES([KINGATE],[kingate],,[
AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
])
+HAVE_FCGI=false
+HAVE_PLAINCGI=false
+PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi],[
+ HAVE_FCGI=true
+],[
+ AC_MSG_NOTICE([no fastcgi support in kingate library])
+])
+PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi],[
+ HAVE_PLAINCGI=true
+],[
+ AC_MSG_NOTICE([no plaincgi support in kingate library])
+])
+if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
+ AC_MSG_ERROR([not a single CGI interface supported in kingate])
+fi
+AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
+AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
+
PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
AC_MSG_ERROR([no dotconf library found])
])
AC_WITH_PCRE([
AC_WITH_PCREPP(,[
AC_MSG_ERROR([no pcre++ library found])
])
],[
AC_MSG_ERROR([no pcre library found])
])