summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-02-13 22:04:58 (UTC)
committer Michael Krelin <hacker@klever.net>2005-02-13 22:04:58 (UTC)
commit5f46976a264df39b847e3095b5babb400ab2a3e7 (patch) (side-by-side diff)
tree059b3a6031dd2f375339a27a4de25af1686b7124 /configure.ac
parent9aa669090e978dce5e1f4d1ca9d23a4d92208518 (diff)
downloadsitecing-5f46976a264df39b847e3095b5babb400ab2a3e7.zip
sitecing-5f46976a264df39b847e3095b5babb400ab2a3e7.tar.gz
sitecing-5f46976a264df39b847e3095b5babb400ab2a3e7.tar.bz2
portability improvements
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0da7658..b9e9b56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,51 +32,53 @@ PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi],[
])
PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi],[
HAVE_PLAINCGI=true
],[
AC_MSG_NOTICE([no plaincgi support in kingate library])
])
if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
AC_MSG_ERROR([not a single CGI interface supported in kingate])
fi
AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
AC_MSG_ERROR([no dotconf library found])
])
AC_WITH_PCRE([
AC_WITH_PCREPP(,[
AC_MSG_ERROR([no pcre++ library found])
])
],[
AC_MSG_ERROR([no pcre library found])
])
+AC_CHECK_FUNC([dlopen],,[
AC_CHECK_LIB([dl],[dlopen],,[
AC_MSG_ERROR([no dlopen library found])
])
+])
AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
WANT_DOXYGEN="yes"
AC_ARG_ENABLE([doxygen],
AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
[
test "${enableval}" = "no" && WANT_DOXYGEN="no"
]
)
if test "${WANT_DOXYGEN}" = "yes" ; then
AC_WITH_DOXYGEN
AC_WITH_DOT
else
AM_CONDITIONAL([HAVE_DOXYGEN],[false])
AM_CONDITIONAL([HAVE_DOT],[false])
fi
AC_CONFIG_FILES([
Makefile
Doxyfile
sitecing.pc
include/Makefile
lib/Makefile