summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-04-25 16:36:32 (UTC)
committer Michael Krelin <hacker@klever.net>2005-04-25 16:36:32 (UTC)
commit981b219f5297ad2ccc1fc1d0e24e41ec009c35a3 (patch) (unidiff)
tree9fa81d7fe70883ad26d946c902ba06edcebd4516 /configure.ac
parent54e344b7e3623e807b893b7febad3adfc6c1648f (diff)
downloadsitecing-981b219f5297ad2ccc1fc1d0e24e41ec009c35a3.zip
sitecing-981b219f5297ad2ccc1fc1d0e24e41ec009c35a3.tar.gz
sitecing-981b219f5297ad2ccc1fc1d0e24e41ec009c35a3.tar.bz2
moved a few utility functions to konforka and bumped konforka version requirement accordingly
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8aa142..fde326b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,89 +1,93 @@
1AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net]) 1AC_INIT([sitecing], [0.0.1], [sitecing-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h]) 2AC_CONFIG_SRCDIR([include/sitecing/sitecing_parser.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_AWK 7AC_PROG_AWK
8AC_PROG_CXX 8AC_PROG_CXX
9AC_PROG_CC 9AC_PROG_CC
10AM_PROG_LEX 10AM_PROG_LEX
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12 12
13AC_HEADER_STDC 13AC_HEADER_STDC
14AC_CHECK_HEADERS([stdlib.h unistd.h]) 14AC_CHECK_HEADERS([stdlib.h unistd.h])
15 15
16AC_C_CONST 16AC_C_CONST
17 17
18AC_FUNC_MALLOC 18AC_FUNC_MALLOC
19AC_FUNC_REALLOC 19AC_FUNC_REALLOC
20 20
21AC_WITH_PKGCONFIG 21AC_WITH_PKGCONFIG
22 22
23PKG_CHECK_MODULES([KONFORKA],[konforka >= 0.0.1],,[
24 AC_MSG_ERROR([no proper version of konforka library found, get it at http://kin.klever.net/konforka/])
25])
26
23PKG_CHECK_MODULES([KINGATE],[kingate >= 0.0.1],,[ 27PKG_CHECK_MODULES([KINGATE],[kingate >= 0.0.1],,[
24 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/]) 28 AC_MSG_ERROR([no kingate library found, get it at http://kin.klever.net/kingate/])
25]) 29])
26HAVE_FCGI=false 30HAVE_FCGI=false
27HAVE_PLAINCGI=false 31HAVE_PLAINCGI=false
28PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi >= 0.0.1],[ 32PKG_CHECK_MODULES([KINGATE_FCGI],[kingate-fcgi >= 0.0.1],[
29 HAVE_FCGI=true 33 HAVE_FCGI=true
30],[ 34],[
31 AC_MSG_NOTICE([no fastcgi support in kingate library]) 35 AC_MSG_NOTICE([no fastcgi support in kingate library])
32]) 36])
33PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi >= 0.0.1],[ 37PKG_CHECK_MODULES([KINGATE_PLAINCGI],[kingate-plaincgi >= 0.0.1],[
34 HAVE_PLAINCGI=true 38 HAVE_PLAINCGI=true
35],[ 39],[
36 AC_MSG_NOTICE([no plaincgi support in kingate library]) 40 AC_MSG_NOTICE([no plaincgi support in kingate library])
37]) 41])
38if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then 42if ! (${HAVE_FCGI} || ${HAVE_PLAINCGI}) ; then
39 AC_MSG_ERROR([not a single CGI interface supported in kingate]) 43 AC_MSG_ERROR([not a single CGI interface supported in kingate])
40fi 44fi
41AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}]) 45AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
42AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}]) 46AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
43 47
44PKG_CHECK_MODULES([DOTCONF],[dotconf],,[ 48PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
45 AC_MSG_ERROR([no dotconf library found]) 49 AC_MSG_ERROR([no dotconf library found])
46]) 50])
47 51
48AC_WITH_PCRE([ 52AC_WITH_PCRE([
49 AC_WITH_PCREPP(,[ 53 AC_WITH_PCREPP(,[
50 AC_MSG_ERROR([no pcre++ library found]) 54 AC_MSG_ERROR([no pcre++ library found])
51 ]) 55 ])
52],[ 56],[
53 AC_MSG_ERROR([no pcre library found]) 57 AC_MSG_ERROR([no pcre library found])
54]) 58])
55 59
56AC_CHECK_FUNC([dlopen],,[ 60AC_CHECK_FUNC([dlopen],,[
57 AC_CHECK_LIB([dl],[dlopen],,[ 61 AC_CHECK_LIB([dl],[dlopen],,[
58 AC_MSG_ERROR([no dlopen library found]) 62 AC_MSG_ERROR([no dlopen library found])
59 ]) 63 ])
60]) 64])
61 65
62AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 66AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
63 67
64WANT_DOXYGEN="yes" 68WANT_DOXYGEN="yes"
65AC_ARG_ENABLE([doxygen], 69AC_ARG_ENABLE([doxygen],
66 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 70 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
67 [ 71 [
68 test "${enableval}" = "no" && WANT_DOXYGEN="no" 72 test "${enableval}" = "no" && WANT_DOXYGEN="no"
69 ] 73 ]
70) 74)
71if test "${WANT_DOXYGEN}" = "yes" ; then 75if test "${WANT_DOXYGEN}" = "yes" ; then
72 AC_WITH_DOXYGEN 76 AC_WITH_DOXYGEN
73 AC_WITH_DOT 77 AC_WITH_DOT
74else 78else
75 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 79 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
76 AM_CONDITIONAL([HAVE_DOT],[false]) 80 AM_CONDITIONAL([HAVE_DOT],[false])
77fi 81fi
78 82
79AC_CONFIG_FILES([ 83AC_CONFIG_FILES([
80 Makefile 84 Makefile
81 Doxyfile 85 Doxyfile
82 sitecing.pc 86 sitecing.pc
83 include/Makefile 87 include/Makefile
84 lib/Makefile 88 lib/Makefile
85 share/Makefile 89 share/Makefile
86 src/Makefile 90 src/Makefile
87 components/Makefile 91 components/Makefile
88]) 92])
89AC_OUTPUT 93AC_OUTPUT