summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Unidiff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cf1fe6d
--- a/dev/null
+++ b/Makefile.am
@@ -0,0 +1,35 @@
1EXTRA_DIST = \
2 $(addprefix htdocs/,.htaccess index.chtml sources.chtml style.css view.chtml) \
3 $(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \
4 $(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \
5 $(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
6 $(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
7 $(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \
8 autogen.sh \
9 NEWS NEWS.xml NEWS.xsl
10
11DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck
12
13all-local: NEWS sitecode restart restart-apache
14distclean-local:
15 rm -rf config.sitecing \
16 logs fastcgi-bin run cache
17
18NEWS: NEWS.xsl NEWS.xml
19 ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
20
21sitecode: conf/sitecing.conf include/acconfig.h
22 ${SHELL} bin/build
23restart: conf/sitecing.conf conf/dudki.conf
24if !DISTCHECKING
25if HAVE_DUDKI
26 sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r"
27else
28 kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run
29endif
30endif !DISTCHECKING
31
32restart-apache: conf/httpd.conf
33if !DISTCHECKING
34 @APACHE_RESTART_CMD@
35endif !DISTCHECKING