summaryrefslogtreecommitdiffabout
path: root/Makefile.am
Side-by-side diff
Diffstat (limited to 'Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cf1fe6d
--- a/dev/null
+++ b/Makefile.am
@@ -0,0 +1,35 @@
+EXTRA_DIST = \
+ $(addprefix htdocs/,.htaccess index.chtml sources.chtml style.css view.chtml) \
+ $(addprefix htdocs/ancestry/,.htaccess layout.chtml page.chtml sources.chtml) \
+ $(addprefix htdocs/exceptions/,index.chtml preprocess.chtml compile.chtml runtime.chtml) \
+ $(addprefix htdocs/exceptions/development/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
+ $(addprefix htdocs/exceptions/production/,.htaccess .scrc compile.chtml compile.html preprocess.chtml runtime.chtml erroneous.h) \
+ $(addprefix htdocs/handlers/,.htaccess exception_dev exception_prod) \
+ autogen.sh \
+ NEWS NEWS.xml NEWS.xsl
+
+DISTCHECK_CONFIGURE_FLAGS=--enable-distcheck
+
+all-local: NEWS sitecode restart restart-apache
+distclean-local:
+ rm -rf config.sitecing \
+ logs fastcgi-bin run cache
+
+NEWS: NEWS.xsl NEWS.xml
+ ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml
+
+sitecode: conf/sitecing.conf include/acconfig.h
+ ${SHELL} bin/build
+restart: conf/sitecing.conf conf/dudki.conf
+if !DISTCHECKING
+if HAVE_DUDKI
+ sudo ${SHELL} -c "@DUDKI@ -k @dudki_id@ ; sleep 3 ; @DUDKI@ -r"
+else
+ kill `cat run/sitecing.pid` ; sleep 3 ; ${SHELL} bin/run
+endif
+endif !DISTCHECKING
+
+restart-apache: conf/httpd.conf
+if !DISTCHECKING
+ @APACHE_RESTART_CMD@
+endif !DISTCHECKING