summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0da7658..b9e9b56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,26 +44,28 @@ AM_CONDITIONAL([HAVE_PLAINCGI],[${HAVE_PLAINCGI}])
44PKG_CHECK_MODULES([DOTCONF],[dotconf],,[ 44PKG_CHECK_MODULES([DOTCONF],[dotconf],,[
45 AC_MSG_ERROR([no dotconf library found]) 45 AC_MSG_ERROR([no dotconf library found])
46]) 46])
47 47
48AC_WITH_PCRE([ 48AC_WITH_PCRE([
49 AC_WITH_PCREPP(,[ 49 AC_WITH_PCREPP(,[
50 AC_MSG_ERROR([no pcre++ library found]) 50 AC_MSG_ERROR([no pcre++ library found])
51 ]) 51 ])
52],[ 52],[
53 AC_MSG_ERROR([no pcre library found]) 53 AC_MSG_ERROR([no pcre library found])
54]) 54])
55 55
56AC_CHECK_LIB([dl],[dlopen],,[ 56AC_CHECK_FUNC([dlopen],,[
57 AC_MSG_ERROR([no dlopen library found]) 57 AC_CHECK_LIB([dl],[dlopen],,[
58 AC_MSG_ERROR([no dlopen library found])
59 ])
58]) 60])
59 61
60AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 62AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
61 63
62WANT_DOXYGEN="yes" 64WANT_DOXYGEN="yes"
63AC_ARG_ENABLE([doxygen], 65AC_ARG_ENABLE([doxygen],
64 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 66 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
65 [ 67 [
66 test "${enableval}" = "no" && WANT_DOXYGEN="no" 68 test "${enableval}" = "no" && WANT_DOXYGEN="no"
67 ] 69 ]
68) 70)
69if test "${WANT_DOXYGEN}" = "yes" ; then 71if test "${WANT_DOXYGEN}" = "yes" ; then