summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac166
1 files changed, 166 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..dc1beb3
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,166 @@
1AC_INIT([sitecing-showcase], [0.0], [sitecing-bugs@klever.net])
2AC_CONFIG_SRCDIR([htdocs/index.chtml])
3AC_CONFIG_AUX_DIR([aux])
4AC_CONFIG_HEADER([include/acconfig.h])
5AM_INIT_AUTOMAKE([dist-bzip2])
6
7AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
8
9PKG_CHECK_MODULES([SITECING],[sitecing],,[
10 AC_MSG_ERROR([site-C-ing not found. get it at http://kin.klever.net/sitecing/])
11])
12sitecing_prefix="$(${PKG_CONFIG} --variable=prefix sitecing)"
13sitecing_bindir="$(${PKG_CONFIG} --variable=bindir sitecing)"
14AC_MSG_CHECKING([for sitecing-fastcgi binary])
15sitecing_fastcgi="${sitecing_bindir}/sitecing-fastcgi"
16if test -x "${sitecing_fastcgi}" ; then
17 AC_MSG_RESULT([found ${sitecing_fastcgi}])
18else
19 AC_MSG_RESULT([not found])
20 AC_MSG_ERROR([broken site-C-ing install detected])
21fi
22AC_MSG_CHECKING([for sitecing-build binary])
23sitecing_build="${sitecing_bindir}/sitecing-build"
24if test -x "${sitecing_build}" ; then
25 AC_MSG_RESULT([found ${sitecing_build}])
26else
27 AC_MSG_RESULT([not found])
28 AC_MSG_ERROR([broken site-C-ing install detected])
29fi
30AC_SUBST([sitecing_prefix])
31AC_SUBST([sitecing_bindir])
32AC_SUBST([sitecing_fastcgi])
33AC_SUBST([sitecing_build])
34
35config_sitecing="config.sitecing"
36rm -f "${config_sitecing}"
37SC_BUILD_CONF([${config_sitecing}],[CPPFLAGS],[${SITECING_CFLAGS}])
38SC_BUILD_CONF([${config_sitecing}],[LDFLAGS],[${SITECING_LIBS}])
39AC_SUBST_FILE([config_sitecing])
40
41SC_WEB_ROOT([web_src_root],[web_run_root])
42SC_USER([sitecing_user])
43
44AC_DEFINE_UNQUOTED([WEB_ROOT],["${web_src_root}"],[the site root])
45AC_DEFINE_UNQUOTED([WEB_SRC_ROOT],["${web_src_root}"],[the site root])
46AC_DEFINE_UNQUOTED([WEB_RUN_ROOT],["${web_run_root}"],[the site root])
47
48v_hostname="$(hostname)"
49AC_MSG_CHECKING([for virtual host name])
50AC_ARG_WITH([vhostname],
51 AC_HELP_STRING([--with-vhostname=virtual-host-name],[set the apache ServerName of VirtualHost]),
52 [
53 v_hostname="${withval}"
54 ]
55)
56AC_MSG_RESULT([${v_hostname}])
57AC_SUBST([v_hostname])
58
59HAVE_DUDKI="false"
60WANT_DUDKI="true"
61AC_ARG_ENABLE([dudki],
62 AC_HELP_STRING([--disable-dudki],[disable the use of dudki! to restart daemon]),
63 [
64 test "${enableval}" = "no" && WANT_DUDKI="false"
65 ]
66)
67if ${WANT_DUDKI} ; then
68 AC_PATH_PROG([DUDKI],[dudki],[false],[${PATH}:/usr/local/sbin:/usr/sbin])
69 test "${DUDKI}" = "false" || HAVE_DUDKI="true"
70fi
71AM_CONDITIONAL([HAVE_DUDKI],[${HAVE_DUDKI}])
72
73dudki_id=sitecing-showcase
74AC_ARG_WITH([dudki-id],
75 AC_HELP_STRING([--with-dudki-id],[specify dudki process id]),
76 [
77 dudki_id="${withval}"
78 ]
79)
80AC_SUBST([dudki_id])
81
82APACHE_RESTART_CMD="false"
83AC_ARG_WITH([apache-restart-cmd],
84 AC_HELP_STRING([--with-apache-restart-cmd=command],[use the specified command to restart apache]),
85 [
86 test "${withval}" = "no" || APACHE_RESTART_CMD="${withval}"
87 ]
88)
89if test "${APACHE_RESTART_CMD}" = "false" ; then
90 AC_PATH_PROG([APACHECTL],[apachectl],[false],[${PATH}:/usr/sbin:/usr/local/sbin])
91 if test "${APACHECTL}" != "false" ; then
92 APACHE_RESTART_CMD="sudo ${APACHECTL} graceful"
93 else
94 AC_PATH_PROG([APACHE2CTL],[apache2ctl],[false],[${PATH}:/usr/sbin:/usr/local/sbin])
95 if test "${APACHE2CTL}" != "false" ; then
96 APACHE_RESTART_CMD="sudo ${APACHE2CTL} graceful"
97 else
98 for i_s in /etc/init.d/apache /etc/init.d/apache2 ; do
99 AC_MSG_CHECKING([for ${i_s}])
100 if test -x ${i_s} ; then
101 AC_MSG_RESULT([found])
102 APACHE_RESTART_CMD="sudo ${i_s} restart"
103 break
104 fi
105 AC_MSG_RESULT([not found])
106 done
107 fi
108 fi
109fi
110if test "${APACHE_RESTART_CMD}" = "false" ; then
111 AC_MSG_NOTICE([couldn't figure out how to restart apache. use --with-apache-restart-cmd])
112fi
113AC_SUBST([APACHE_RESTART_CMD])
114
115
116AC_MSG_CHECKING([if we are in the development environment])
117do_devel="false"
118AC_ARG_ENABLE([development],
119 AC_HELP_STRING([--enable-development],[enable build for development environment]),
120 [
121 if test "${enableval}" = "yes" ; then
122 do_devel="true"
123 fi
124 ]
125)
126build_on_demand="off"
127exception_handler="/handlers/exception_prod"
128if ${do_devel} ; then
129 AC_MSG_RESULT([yes])
130 build_on_demand="on"
131 exception_handler="/handlers/exception_dev"
132 AC_DEFINE([_DEVELOPMENT],,[define if development environment])
133else
134 AC_MSG_RESULT([no])
135fi
136AC_SUBST([build_on_demand])
137AC_SUBST([exception_handler])
138
139DISTCHECKING="false"
140AC_ARG_ENABLE([distcheck],,[
141 DISTCHECKING="true"
142])
143AM_CONDITIONAL([DISTCHECKING],[${DISTCHECKING}])
144
145AC_CONFIG_FILES([
146 Makefile
147 conf/httpd.conf conf/sitecing.conf conf/dudki.conf
148 bin/run bin/build
149])
150AC_CONFIG_COMMANDS([logs/stamp],[touch logs/stamp])
151AC_CONFIG_COMMANDS([fastcgi-bin/stamp],[touch fastcgi-bin/stamp])
152AC_CONFIG_COMMANDS([run/stamp],[touch run/stamp])
153AC_OUTPUT
154
155echo
156echo ===
157echo "virtual host name:" "${v_hostname}"
158echo "project src root: " "${web_src_root}"
159echo "project run root: " "${web_run_root}"
160echo "sitecing user: " "${sitecing_user}"
161echo "dudki id: " "${dudki_id}"
162echo "development: " "${do_devel}"
163echo "site-C-ing prefix:" "${sitecing_prefix}"
164echo ===
165echo
166dnl vim:set ft=m4: