summaryrefslogtreecommitdiff
authorMichael Krelin <hacker@klever.net>2007-02-21 21:12:24 (UTC)
committer Michael Krelin <hacker@klever.net>2007-02-21 21:12:24 (UTC)
commita8f232e4964c576585669d2040b079ae78c4c63d (patch) (side-by-side diff)
tree4db9ff44beec560d0d692300ccfbf8dbef58b5cc
parent13494efdcf104f4fb71d9034f92172a73a103b1d (diff)
downloadkintoo-a8f232e4964c576585669d2040b079ae78c4c63d.zip
kintoo-a8f232e4964c576585669d2040b079ae78c4c63d.tar.gz
kintoo-a8f232e4964c576585669d2040b079ae78c4c63d.tar.bz2
konforka-svn
Diffstat (more/less context) (show whitespace changes)
-rw-r--r--dev-libs/konforka-svn/Manifest7
-rw-r--r--dev-libs/konforka-svn/files/digest-konforka-svn-2370
-rw-r--r--dev-libs/konforka-svn/konforka-svn-237.ebuild40
-rw-r--r--profiles/categories1
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/konforka-svn/Manifest b/dev-libs/konforka-svn/Manifest
new file mode 100644
index 0000000..1a41dc9
--- a/dev/null
+++ b/dev-libs/konforka-svn/Manifest
@@ -0,0 +1,7 @@
+EBUILD konforka-svn-237.ebuild 882 RMD160 5b47f18f33d198f847fc7f011d305c4525443134 SHA1 1f28833f29d0f9ee5637f31feb27c1d8359eb6d7 SHA256 a9d9867bb42b8e1ed780ac27391d048993a8de290303a9e682d5264af0de053e
+MD5 37bcd747359b864ae85f73637042b284 konforka-svn-237.ebuild 882
+RMD160 5b47f18f33d198f847fc7f011d305c4525443134 konforka-svn-237.ebuild 882
+SHA256 a9d9867bb42b8e1ed780ac27391d048993a8de290303a9e682d5264af0de053e konforka-svn-237.ebuild 882
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-konforka-svn-237 0
+RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-konforka-svn-237 0
+SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-konforka-svn-237 0
diff --git a/dev-libs/konforka-svn/files/digest-konforka-svn-237 b/dev-libs/konforka-svn/files/digest-konforka-svn-237
new file mode 100644
index 0000000..e69de29
--- a/dev/null
+++ b/dev-libs/konforka-svn/files/digest-konforka-svn-237
diff --git a/dev-libs/konforka-svn/konforka-svn-237.ebuild b/dev-libs/konforka-svn/konforka-svn-237.ebuild
new file mode 100644
index 0000000..929952f
--- a/dev/null
+++ b/dev-libs/konforka-svn/konforka-svn-237.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion eutils
+
+ESVN_REPO_URI="http://svn.klever.net/kin/konforka/trunk"
+ESVN_PROJECT="konforka"
+ESVN_BOOTSTRAP="./autogen.sh --help >&/dev/null"
+ESVN_OPTIONS="-r${PV}"
+
+DESCRIPTION="A convenience library for KIN project"
+HOMEPAGE="http://kin.klever.net/konforka/"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres"
+
+RDEPEND="
+ postgres? ( dev-libs/libpqxx )
+ !dev-libs/konforka
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool
+"
+
+src_compile() {
+ econf \
+ PKG_CONFIG_PATH="/usr/$(get_libdir)/pkgconfig:${PKG_CONFIG_PATH}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYING NEWS
+}
diff --git a/profiles/categories b/profiles/categories
index a70619b..a25996c 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1 +1,2 @@
+dev-libs
sys-apps