summaryrefslogtreecommitdiff
authorMichael Krelin <hacker@klever.net>2007-02-21 21:12:24 (UTC)
committer Michael Krelin <hacker@klever.net>2007-02-21 21:12:24 (UTC)
commita8f232e4964c576585669d2040b079ae78c4c63d (patch) (unidiff)
tree4db9ff44beec560d0d692300ccfbf8dbef58b5cc
parent13494efdcf104f4fb71d9034f92172a73a103b1d (diff)
downloadkintoo-a8f232e4964c576585669d2040b079ae78c4c63d.zip
kintoo-a8f232e4964c576585669d2040b079ae78c4c63d.tar.gz
kintoo-a8f232e4964c576585669d2040b079ae78c4c63d.tar.bz2
konforka-svn
Diffstat (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/konforka-svn/Manifest7
-rw-r--r--dev-libs/konforka-svn/files/digest-konforka-svn-2370
-rw-r--r--dev-libs/konforka-svn/konforka-svn-237.ebuild40
-rw-r--r--profiles/categories1
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/konforka-svn/Manifest b/dev-libs/konforka-svn/Manifest
new file mode 100644
index 0000000..1a41dc9
--- a/dev/null
+++ b/dev-libs/konforka-svn/Manifest
@@ -0,0 +1,7 @@
1EBUILD konforka-svn-237.ebuild 882 RMD160 5b47f18f33d198f847fc7f011d305c4525443134 SHA1 1f28833f29d0f9ee5637f31feb27c1d8359eb6d7 SHA256 a9d9867bb42b8e1ed780ac27391d048993a8de290303a9e682d5264af0de053e
2MD5 37bcd747359b864ae85f73637042b284 konforka-svn-237.ebuild 882
3RMD160 5b47f18f33d198f847fc7f011d305c4525443134 konforka-svn-237.ebuild 882
4SHA256 a9d9867bb42b8e1ed780ac27391d048993a8de290303a9e682d5264af0de053e konforka-svn-237.ebuild 882
5MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-konforka-svn-237 0
6RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-konforka-svn-237 0
7SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-konforka-svn-237 0
diff --git a/dev-libs/konforka-svn/files/digest-konforka-svn-237 b/dev-libs/konforka-svn/files/digest-konforka-svn-237
new file mode 100644
index 0000000..e69de29
--- a/dev/null
+++ b/dev-libs/konforka-svn/files/digest-konforka-svn-237
diff --git a/dev-libs/konforka-svn/konforka-svn-237.ebuild b/dev-libs/konforka-svn/konforka-svn-237.ebuild
new file mode 100644
index 0000000..929952f
--- a/dev/null
+++ b/dev-libs/konforka-svn/konforka-svn-237.ebuild
@@ -0,0 +1,40 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit subversion eutils
6
7ESVN_REPO_URI="http://svn.klever.net/kin/konforka/trunk"
8ESVN_PROJECT="konforka"
9ESVN_BOOTSTRAP="./autogen.sh --help >&/dev/null"
10ESVN_OPTIONS="-r${PV}"
11
12DESCRIPTION="A convenience library for KIN project"
13HOMEPAGE="http://kin.klever.net/konforka/"
14LICENSE="MIT"
15SLOT="0"
16KEYWORDS="~amd64 ~x86"
17IUSE="postgres"
18
19RDEPEND="
20 postgres? ( dev-libs/libpqxx )
21 !dev-libs/konforka
22"
23DEPEND="${RDEPEND}
24 dev-util/pkgconfig
25 sys-devel/autoconf
26 sys-devel/automake
27 sys-devel/libtool
28"
29
30src_compile() {
31 econf \
32 PKG_CONFIG_PATH="/usr/$(get_libdir)/pkgconfig:${PKG_CONFIG_PATH}" \
33 || die "econf failed"
34 emake || die "emake failed"
35}
36
37src_install() {
38 emake DESTDIR="${D}" install || die "emake install failed"
39 dodoc AUTHORS COPYING NEWS
40}
diff --git a/profiles/categories b/profiles/categories
index a70619b..a25996c 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1 +1,2 @@
1dev-libs
1sys-apps 2sys-apps