summaryrefslogtreecommitdiff
path: root/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch
Unidiff
Diffstat (limited to 'app-pda/pilot-link/files/pilot-link-0.12.2-build.patch') (more/less context) (ignore whitespace changes)
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.2-build.patch89
1 files changed, 0 insertions, 89 deletions
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch b/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch
deleted file mode 100644
index e26ccb7..0000000
--- a/app-pda/pilot-link/files/pilot-link-0.12.2-build.patch
+++ b/dev/null
@@ -1,89 +0,0 @@
1diff --git a/bindings/Java/Makefile.am b/bindings/Java/Makefile.am
2index a2ead24..1500dcd 100644
3--- a/bindings/Java/Makefile.am
4+++ b/bindings/Java/Makefile.am
5@@ -67,6 +67,8 @@ java_classes= \
6 datebooktst.class\
7 adrtest.class
8
9+$(java_classes): java_compile
10+
11 java_compile: $(java_files)
12 $(JAVAC) -d . $(java_files)
13
14@@ -81,16 +83,16 @@ java_pisock: java_compile java_lib java_jar
15 install: all
16 ARCH=""; \
17 for a in i386 amd64 ppc; do \
18 - if [ -e ${JAVABASE}/jre/lib/${a} ]; then \
19 - ARCH="${a}"; \
20 + if [ -e ${JAVABASE}/jre/lib/$${a} ]; then \
21 + ARCH="$${a}"; \
22 break; \
23 fi; \
24 done; \
25 -if [ -n "${ARCH}" ]; then \
26 +if [ -n "$${ARCH}" ]; then \
27 echo "Unknown architecture. Copy lipijsock.so to ${JAVABASE}/jre/lib/ARCH/"; \
28 else \
29 - mkdir -p "$(DESTDIR)${JAVABASE}/jre/lib/${ARCH}" && \
30 - cp libjpisock.so "$(DESTDIR)${JAVABASE}/jre/lib/${ARCH}"; \
31 + mkdir -p "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}" && \
32 + cp libjpisock.so "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}"; \
33 echo "done."; \
34 fi
35
36diff --git a/configure.ac b/configure.ac
37index 68a05f2..4da0626 100644
38--- a/configure.ac
39+++ b/configure.ac
40@@ -220,6 +220,7 @@ AC_MSG_RESULT($enable_conduits)
41 dnl ******************************
42 dnl PNG Support
43 dnl ******************************
44+msg_png=no
45 if test "x$enable_conduits" != "xno"; then
46 have_png=no
47
48@@ -254,6 +255,7 @@ if test "x$enable_conduits" != "xno"; then
49 if test "$have_png" = yes; then
50 AC_DEFINE(HAVE_PNG, 1, [Define if we have PNG support])
51 have_png=yes
52 + msg_png=yes
53 fi
54 fi
55 fi
56@@ -351,12 +353,13 @@ PKG_CHECK_MODULES(BLUEZ, bluez, have_bluez=yes, AC_MSG_RESULT(no))
57 AC_MSG_CHECKING([for BlueZ bluetooth support])
58 AC_ARG_WITH(bluez,
59 AC_HELP_STRING([--with-bluez],
60- [Enable usage of BlueZ]),,
61+ [Enable usage of BlueZ]),[use_bluez="$withval"],
62 use_bluez=auto)
63 if test "x$use_bluez" != "xno"; then
64 if test "x$have_bluez" = xno && test "x$use_bluez" = xyes; then
65 AC_MSG_ERROR([BlueZ explicitly requested but no support found])
66 fi
67 +use_bluez="$have_bluez"
68 if test "x$have_bluez" = xyes; then
69 AC_DEFINE(HAVE_BLUEZ, 1, [Define if we have BlueZ bluetooth support])
70 AC_MSG_RESULT([enabled])
71@@ -366,7 +369,7 @@ if test "x$use_bluez" != "xno"; then
72 fi
73 fi
74
75-AM_CONDITIONAL(WITH_BLUEZ, test x$have_bluez = "xyes")
76+AM_CONDITIONAL(WITH_BLUEZ, test x$use_bluez != "xno")
77
78
79 dnl *********************************
80diff --git a/pilot-link.m4.in b/pilot-link.m4.in
81index 129dfc3..a271c74 100644
82--- a/pilot-link.m4.in
83+++ b/pilot-link.m4.in
84@@ -1,5 +1,3 @@
85-AC_DEFUN([IT_PROG_INTLTOOL], [AC_PREREQ([2.50])dnl
86-
87 AC_DEFUN([AC_PILOT_LINK_HOOK],
88 [
89 PILOT_LINK_VERS=0