summaryrefslogtreecommitdiff
path: root/app-pda/pilot-link/pilot-link-0.12.2.ebuild
Unidiff
Diffstat (limited to 'app-pda/pilot-link/pilot-link-0.12.2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.2.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/app-pda/pilot-link/pilot-link-0.12.2.ebuild b/app-pda/pilot-link/pilot-link-0.12.2.ebuild
deleted file mode 100644
index 9c38cb4..0000000
--- a/app-pda/pilot-link/pilot-link-0.12.2.ebuild
+++ b/dev/null
@@ -1,70 +0,0 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5WANT_AUTOCONF="latest"
6WANT_AUTOMAKE="1.9"
7inherit perl-module eutils autotools toolchain-funcs
8
9DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
10HOMEPAGE="http://www.pilot-link.org/"
11SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
12
13LICENSE="|| ( GPL-2 LGPL-2 )"
14SLOT="0"
15KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
16IUSE="threads usb png bluetooth readline perl java tcl python"
17
18RDEPEND="virtual/libc
19 sys-libs/ncurses
20 usb? ( dev-libs/libusb )
21 png? ( media-libs/libpng )
22 bluetooth? ( net-wireless/bluez-libs )
23 readline? ( sys-libs/readline )
24 perl? ( dev-lang/perl )
25 java? ( virtual/jre )
26 tcl? ( dev-lang/tcl dev-lang/tk )
27 python? ( dev-lang/python )
28 "
29DEPEND="${RDEPEND}
30 java? ( virtual/jdk )
31 "
32
33src_unpack() {
34 unpack ${A}
35 cd "${S}"
36 epatch "${FILESDIR}/${P}-build.patch"
37 eautoconf
38 eautomake
39}
40
41src_compile() {
42 econf \
43 --includedir=/usr/include/libpisock \
44 --enable-conduits \
45 $(use_enable threads) $(use_enable usb libusb) \
46 $(use_with png libpng $(libpng-config --prefix)) \
47 $(use_with bluetooth bluez) \
48 $(use_with readline) $(use_with perl) $(use_with java) \
49 $(use_with tcl tcl /usr/$(get_libdir)) \
50 $(use_with python) \
51 || die "econf failed"
52 emake || die "emake failed"
53
54 if use perl ; then
55 cd "${S}/bindings/Perl"
56 perl-module_src_prep
57 perl-module_src_compile
58 fi
59}
60
61src_install() {
62 emake DESTDIR="${D}" install || die "emake install failed"
63
64 dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
65
66 if use perl ; then
67 cd "${S}/bindings/Perl"
68 perl-module_src_install
69 fi
70}